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1 MIKE 21 Mooring Analysis Step-by-Step Training Guide 

This training guide includes the following four step by step examples: 

 

The first example is a simple domain-independent example relying on 0D (time series) 

wave forcing used on a vessel in a user defined local domain, which on a basic level 

showcases the combined usage of Frequency Response Calculator and MIKE 21 

Mooring Analysis (MA) in order to perform a simple mooring analysis. 

 

The second example is more advanced and demonstrates the powerful combined 

workflow between MIKE 21 HD, Frequency Response Calculator and MIKE 21 MA in 

order to calculate the moored vessel motions of a tanker induced by a passing (transiting) 

vessel within the Port of Brisbane navigation channel. This example provides guidance on 

the entire simulation, from setting up and running the hydrodynamic model, to creating a 

moving pressure field and running a dynamic mooring analysis.  

 

The third example details how to set up MIKE 21 MA for multibody simulations. Two bulk 

carriers, moored side by side, are subject to waves. 

 

The fourth example demonstrates how to set up a Trelleborg AutoMoor™ automatic 

mooring unit in a MIKE 21 Mooring Analysis simulation through text edits to the *.m21ma 

input file. 

 

In addition another example is provided in the example folder. The Simple Port folder 

contains the setups to show additional ways for including input data, e.g. from MIKE 21 

Boussinesq Wave (BW) and MIKE 3 Wave FM. The description of this is included in the 

User Guide. 

 

Note: You need to install the example files into a folder to which you have write access. 

 

Note: If you have executed previous models from MIKE Zero project mode, where the 

output data is going to be used as input data in a subsequent MIKE 21 Mooring Analysis 

execution, please be aware that all the result files will be gathered in a common Result 

folder next to the (.mzp) file.  

 

This means that if you are running the examples on basis of MZ project mode, then the 

paths to these files needs to be updated, as the default state of the examples are based 

on non-project mode, where all output data is stored in a Result Files folder next to each 

individual Setup file.  
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2 Example: 0D Wave Forcing on a Vessel 

The step-by-step example in this Chapter demonstrates how to set up a MIKE 21 Mooring 

Analysis simulation, including usage of the Frequency Response Calculator, running the 

model and doing a preliminary analysis of the results. The example calculates vessel 

motions in 6-DoF (Six Degrees of Freedom) of a moored tanker subjected to a time series 

of incident wave conditions (0D wave forcing). 

 

2.1 Step 1 – Launch the Frequency Response Calculator 

The first step in any mooring analysis is to create a Frequency Response Calculator 

(FRC) setup, in order to obtain the frequency response data for the vessel in question. 

From the MIKE Zero page the (.fresponse) editor is launched by clicking: 

 

‘File’ → ‘New’ → ‘File…’  

 

 The (.fresponse) editor can be found under the Maritime subgroup of MIKE 21. 

 

 
 
Figure 2-1 Location of Frequency Response Calculator setup editor 

2.2 Step 2 - Create a Frequency Response Calculator setup 

The set of steps below outlines how to create a new FRC setup. 

 

1. Create a new instance of the (.fresponse) editor as shown in Figure 2-1 by clicking 

OK. The FRC main page (Figure 2-2) should appear on the screen. 
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Figure 2-2  FRC main page 

 

2. Save the file: Select ‘File’ → ’Save’ and save the filename in the root folder: 

(<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Setups\Frequency 

Response.fresponse). 

2.3 Step 3 - Populate the FRC Setup with Data 

Below all the sequential steps for all FRC GUI dialogs are described in descending order: 

 

1. Dialog: Vessel Configuration  

This is the first dialog to consider when setting up FRC. 

 

Under the ‘Configuration’ tab, select ‘New Vessel’ and provide the vessel the name 

‘DHI_Vessel’. Under common conditions use the following values: Set Water depth 

to 15 m and Density of water to 1020 kg/m3. 

 

Under the ‘Vessel positions’ tab, select Amidship in domain. Leave the default 

values for the vessel positions at 0 m for both the x- and y- axis. 
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Figure 2-3  Vessel configuration dialog 

 

Finally, clicking on the ‘Go to …’ button under the ‘Configuration’ tab will take you 

to the Vessel Instance dialog ‘DHI_Vessel’. 

 

2. Dialog: Vessel Instance  

In this dialog you are to specify the vessel grid representing the 3D spatial vessel hull 

and the fundamental conditions which apply. 

 

This dialog is divided into three tabs: Vessel Characteristics, where the 

fundamental data for the vessel instance are to be provided, Freedom of motion 

where users are to define whether the vessel (or body) is freely floating or locked in 

motion (e.g. port structures) and Vessel View, where the deck plane and waterline 

contours can be inspected spatially in an XY coordinate system encapsulating the 

vessel. 

 

On the Vessel Characteristics tab start loading in the vessel grid: 

Leave the delimiter to be Space, and select the following vessel grid file: 

< example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave 

Forcing\Inputs\VesselGrid\Tanker.grd 

 

When the vessel grid is loaded, the remaining parameters on the Vessel 

Characteristics will be automatically updated with default values derived from the 

vessel hull itself. 

 

In this example, the values shown in Table 2.1 should be applied: 
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Table 2.1 Moored vessel parameters 

 

Vessel Scaling (X-Dim)  1 

Vessel Scaling (Y-Dim) 1 

Vessel Scaling (Z-Dim) 1 

rxx 8.95 [m] 

ryy 55.95 [m] 

rzz 55.95 [m] 

Vertical Center of Gravity (ZG) 10.8 [m] 

Draft 9.8 [m] 

Deck plane height 17.8 [m] 

 

By setting these parameters as such, the FRC editor will automatically calculate the 

Vessel Statistics (non-editable) under the given conditions as a service for the user. 

These values will be: 

 

 
 

Under the Freedom of Motion tab, select freely floating for the freedom of motion. 

 

Finally, you can inspect the relative position of the waterline and deck plane contours 

by switching to the Vessel View tab, cf. Figure 2-4. The deck plane height can be 

changed using the slider or a specific value in meters can be provided (distance from 

the keel). By activating the check box “Display isolines”, the user obtains the view on 

the vertical isolines to get an improved impression of the vessel hull shape. 
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Figure 2-4 The Vessel View tab 

 

3. Dialog: Computational Settings 

In this dialog, leave the settings as default:  Simulation mode = M21 Mooring 

Analysis compatible mode, and Number of frequencies to solve = 256. 

 

 
 

Figure 2-5 Computational Settings dialog 

 

4. Dialog: Wave Drift Forces 

Do not include 2nd order Wave drift forces. 
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Figure 2-6 Wave Drift Forces dialog 

 

5. Dialog: Outputs 

All output data and file names are pre-populated with default settings. Do not change 

any settings here. The Vessel response output file will be the basis for all 

subsequent analysis. 

 

 
 

Figure 2-7 Outputs dialog 

2.4 Step 4 – Run the FRC Simulation 

Save the (.fresponse) editor and launch the FRC simulation. 

The Launch settings pop-up is launched by clicking Run → Start Simulation … 

 

Prior to the FRC execution, you can on the Parallelization tab in the Launch settings 

pop-up window control how many cores the FRC simulation should utilise (among the 

number of cores available on the hardware). Use the maximum number of cores (default). 

 

Then click OK, and the FRC simulation will begin. 

 

Once the simulation is completed (takes approx. 1 hours on a 4 core PC) please verify 

that the following output file exists: 

 

< example installation folder >\\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Setups\Frequency 

Response - 0D wave forcing.fresponse - Result Files\Vessel_Response.vre 



Example: 0D Wave Forcing on a Vessel  

 9 

2.5 Step 5 – Launch the MIKE 21 Mooring Analysis 

Similar to the Frequency Response Calculator (.fresponse) editor, the MIKE 21 Mooring 

Analysis (.m21ma) editor is also found under the Maritime subgroup of MIKE 21. 

 

 
 
Figure 2-8 Location of MIKE 21 Mooring Analysis setup editor 

2.6 Step 6 - Create a MIKE 21 Mooring Analysis Setup 

The set of steps below outline how to create a new MIKE 21 Mooring Analysis (M21 MA) 

setup. 

 

1. Open a new instance of the (.m21ma) editor as shown in Figure 2-8 by clicking OK. 

The M21 MA main page (Figure 2-9) should appear on the screen. 

 

 
 
Figure 2-9  M21 MA main page 

 

2. Start saving the file: Select ‘File’ → ’Save’ and save the filename in the root folder: 

(<example installation folder>\MIKE Zero 
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Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Setups\Mooring 

setup.m21ma). 

2.7 Step 7 - Populate the MIKE 21 Mooring Analysis setup with data 

Below all the sequential steps for all required M21 MA GUI dialogs are described in 

descending order: 

 

1. Dialog: Domain (and creation of a Domain file) 

The first step in creation of a M21 MA model begins with selecting a Domain file. 

 

Precise domain files displaying the exact positions of berths and breakwater 

structures are essential when utilizing 2D environmental forcing in a mooring study. 

However, for this example we will utilise 0D (time-series) wave data only. We will 

produce a local Domain file with sufficient spatial extent to encapsulate the full 

mooring system. 

 

For illustrative purposes we have included bathymetry values to the domain file, even 

though they are not used in the calculations for 0D wave data. 

 

Create a domain file that can contain the extent of the vessel and mooring system by 

following these steps: 

 

a. File → New File → Grid Series, and click OK 

b. Select ‘Blank Grid’, and click OK 

c. Select Type of file = 2 dimensional grid, and click Next 

 

 
 

Figure 2-10 New Grid dialog – Step 1 of 5 

 

d. Select Map projection: Type = Local Coordinates, and set Easting to -160 [m], 

Northing to -24 [m] and Grid Rotation to 0 [deg], and click Next 

 



Example: 0D Wave Forcing on a Vessel  

 11 

 
 

Figure 2-11 New Grid dialog – Step 2 of 5 

 

e. Set: Axis Type to Equidistant Time Axis, Start time to 01/01/2016 00:00:00, 

Time Step to 1 [s], No. of Timesteps to 1, Number of grid points (J-dir) to 81, 

Number of grid points (K-dir) to 19, Spacing (J-dir) to 4 [m], Spacing (K-dir) to 4 

[m], and click Next 

 

 
 

Figure 2-12 New Grid dialog – Step 3 of 5 

 

f. With respect to item record 1: type name = ‘Bathymetry’, Select Type = 

Bathymetry, set the Land value to 2 [m] and click Next 
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Figure 2-13 New Grid dialog – Step 4 of 5 

 

g. Click Finish 

h. Add grid values to the file: Set all values in row 0-9 to -15 [m], row 10-17 to 2 [m] 

and row 18 to 5 [m]. 

Save the file as: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave 

Forcing\Inputs\Domain\Domain.dfs2 

Finally, select this Domain file in the Domain dialog as shown in Figure 2-14: 

 

 
 

Figure 2-14 Selection of Domain file 
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2. Dialog: Time 

Here you specify the temporal conditions applying for the time-domain computation 

(simulation mode = final computation mode).  

 

Make the following: 

a. Set the No. of timesteps to 500 

b. Set the timestep interval to 0.25 [s] 

c. Set the simulation start date to 01-01-2016 00:00:00 

d. Set the No. of warm up time steps to 0 

e. Set the No. of warm down time steps to 0 

 

3. Dialog: Simulation mode 

Set this to be Convergence mode. 

 

Using convergence mode means that you prior to running the final time-domain 

simulation first will attempt to find the initial vessel displacement leading to a uniform 

tension distribution among all mooring lines. 

 

Subsequently, determining a proper initial vessel displacement is an important pre-

processing step to ensure a subsequent stable time-domain analysis. 

 

4. Dialog: Material Profiles 

Expand the node and go to Line profiles. 

 

5. Dialog: Line profiles 

Insert two Line profiles. Denote the first line ‘Nylon_rope’ and the second line 

‘Steel_wire’. 

 

6. Dialogs: Line profile instances 

On the Nylon_rope instance specify the following: 

a. Total breaking strength = 74 [t] 

b. Failure load = 45 [%] 

c. Linear damping coefficient = 0 [kg/s] 

d. Quadratic damping coefficient = 0 [kg/m] 

Select this line profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Material 

Profiles\Polyamide_Double-Braided.dfs0 

On the Steel_wire instance specify the following: 

a. Total breaking strength = 121 [t] 

b. Failure load = 55 [%] 

c. Linear damping coefficient = 0 [kg/s] 

d. Quadratic damping coefficient = 0 [kg/m] 

Select this line profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Material 

Profiles\SteelLine42mm.dfs0 

After this go to the Fender Profiles dialog. 

 

7. Dialog: Fender profiles 

Insert one Fender profile. Call it ‘SCN1300’ 

 

8. Dialog: Fender profile instance 

Specify this for the ‘SCN1300’ instance: 

a. Max reaction force = 1357 [kN] 

b. Max deflection = 1.3 [m] 
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c. Failure deflection = 75 [%] 

d. Fender friction coefficient = 0.3 

e. Linear damping coefficient = 0 [kg/s] 

f. Fender thickness = 1.495 [m] 

Select this fender profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Material 

Profiles\SuperCone.dfs0 

9. Dialog: AutoMoor profile  

Specify this for the ‘Trellebor00’ instance: 

g. Max reaction force = 1357 [kN] 

h. Max deflection = 1.3 [m] 

i. Failure deflection = 75 [%] 

j. Fender friction coefficient = 0.3 

k. Linear damping coefficient = 0 [kg/s] 

l. Fender thickness = 1.495 [m] 

Select this fender profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Material 

Profiles\SuperCone.dfs0 

 

10. Dialog: Chain Profiles 

 

We will skip usage of chains in this setup, so no chains will be specified. 

 

11. Dialog: Bollard Profiles 

Specify on this instance: 

a. Max. horizontal bollard pull force = 2000 [kN] 

b. Max. vertical bollard pull force = 1000 [kN] 

c. Max. total pull force = 2500 [kN] 

d. Max. vertical line angle = 60 [deg] 

e. Safety threshold = 75 [%] 

. 

12. Dialog: Vessels 

In this dialog you must select the vessel response file generated from the previously 

executed FRC setup: 

< example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Setups\Frequency 

Response - 0D wave forcing.fresponse - Result Files\Vessel_Response.vre 

 

Once the (.vre) file has been successfully loaded into M21 MA it will look like as 

shown in Figure 2-15.  

 

Clicking ‘Go to …’ on the vessel instance ‘DHI_Vessel’ will take you to the vessel 

instance dialog. 
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Figure 2-15  Vessels dialog after successful loading of (.vre) file  

 

13. Dialog: Vessel instance 

On the Vessel data tab, specify the data as shown in Table 2.2:  

 
Table 2.2 Vessel data 

 

Longitudinal Area (Wind) 2000 [m2] 

Transverse Area (Wind) 500 [m2] 

Lpp1 200 [m] 

Loading Condition 90 [%] 

Vessel Class VLCC Conventional 

1 Lpp refers to the length perpendicular of the vessel 

 

Apart from this you will also see a summary of the vertical attributes from the (.vre) 

file. Among these only the deck plane is editable at this stage. Leave it as 17.8 m. 

 

On the Fairlead data tab, load in data for the full set of fairlead positions (vessel 

fixed) from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Vessel Spatial 

Attributes\fairleads.xyz 

 

On the Winch data tab, load in data for the full set of winch positions (vessel fixed) 

from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Vessel Spatial 

Attributes\winches.xyz 

 

These values are as the ones shown in Table 2.3 and Table 2.4.The X and Y values 

are relative to amidship of the vessel and the Z values are relative to the keel. 

 
Table 2.3 Fairlead positions relative to amidship at the vessel 

 

Name X [m] Y [m] Z [m] 
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Fairlead 1 110.455 -1 19.8 

Fairlead 2 110.455 1 19.8 

Fairlead 3 92.455 16 19.3 

Fairlead 4 91.455 16 19.3 

Fairlead 5 76.455 16 17.8 

Fairlead 6 78.455 16 17.8 

Fairlead 7 -83.545 16 17.8 

Fairlead 8 -85.545 16 17.8 

Fairlead 9 -96.545 14 19.3 

Fairlead 10 -98.545 14 19.3 

Fairlead 11 -111.545 1 19.8 

Fairlead 12 -111.545 -1 19.8 

 

 
Table 2.4 Winch positions relative to amidship at the vessel 

 

Name X [m] Y [m] Z [m] 

Winch 1 101.455 -2 19.8 

Winch 2 101.455 2 19.8 

Winch 3 92.455 0 19.3 

Winch 4 91.455 0 19.3 

Winch 5 76.455 0 17.8 

Winch 6 78.455 0 17.8 

Winch 7 -83.545 0 17.8 

Winch 8  -85.545 0 17.8 

Winch 9 -96.545 5 19.3 

Winch 10 -98.545 5 19.3 

Winch 11 -101.545 1 19.8 

Winch 12 -101.545 -1 19.8 

 

 

On the Vessel View tab, you can see where the full set of fairleads and winches are 

positioned relative to the vessel. It should look as seen in Figure 2-16.  
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Figure 2-16 Vessel view after Fairlead and Winch positions have been specified 

 

14. Dialog: Port data 

 

On the Bollard data tab, load in data for the full set of bollard positions (port/land 

fixed) from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Port 

Data\bollards.xyz 

 

On the Fender data tab, load in data for the full set of fender positions (port/land 

fixed) from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Inputs\Port 

Data\fenders.xyz 

 

The bollard and fender positions in the custom made local dfs2 domain are as the 

ones shown in Table 2.5 and Table 2.6. The Z values are relative to the water 

surface.  

 
Table 2.5 Bollard positions in domain 

 

Name Easting [m] Northing [m] Z [m] Bollard profile 

Bollard 1  151.4556 40 3 Bollard Profile 

Bollard 2 121.4556 40 3 Bollard Profile 

Bollard 3 91.4556 40 3 Bollard Profile 

Bollard 4 46.4556 20 3 Bollard Profile 

Bollard 5 -33.5444 20 3 Bollard Profile 
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Bollard 6 -78.5444 40 3 Bollard Profile 

Bollard 7 -98.5444 40 3 Bollard Profile 

Bollard 8 -138.5444 40 3 Bollard Profile 

 
Table 2.6 Fender positions in domain 

 

Fender Name X [m] Y [m] Z [m] Type 

Fender 1 46.4556 16 1 SCN1300 

Fender 2  -33.5444 16 1 SCN1300 

 

 

There is only one material fender profile declared (SCN1300), so both fenders will 

have this profile associated. Set both fender force directions to be 270 [deg] 

(meaning: fender forces goes straight south (eg. straight against the vessel as we 

shall see). The fender force must point towards the vessel and its direction is defined 

as counter-clockwise positive from Easting axis (going to). 

 

On the Port View tab, you can see where the full set of bollards and fenders are 

positioned in the domain. It should look as seen in Figure 2-17. 

 

 

 
 
Figure 2-17 Bollard and Fender positions in the domain 

 

15. Dialog: Mooring setup 

There are two steps in defining the mooring setup and they should be performed in 

this order 

- Position the vessel in the domain, reasonably 

- Specify the mooring lines, by connecting (winch, fairlead, bollard) pairs 
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On the Vessel position and mooring lines tab, specify the vessel position to be at 

(easting, northing) = (0, -1.495) [m] and a vessel rotation of 0 [deg], and click Apply. 

 

You will now see the vessel and its vessel-fixed attributes relative to the port-fixed 

attributes in a default extent as defined by the domain file, see Figure 2-18: 

 

  

 
 
Figure 2-18 Vessel inserted into domain 

 

Now that the vessel has been appropriately positioned, the next step is to define the 

mooring lines. The mooring system we would like to obtain is as given in Table 2.7 . 

 

Each mooring line can be drawn/defined interactively by:   

a. Visual identification of the relevant winch-fairlead-bollard pair, to span the 

mooring line 

b. Initiate the mooring line insertion by: clicking the Vessel-Berth lines icon  

c. Perform the mooring line insertion by: clicking the relevant winch icon, move the 

cursor to the relevant fairlead icon, clicking on the fairlead icon, continue the line 

to the bollard, and finally clicking on the bollard icon. 

 

If you make an error by connecting some incorrect attributes, then delete the line 

again by selecting the delete line icon  and subsequently click on the given line. 

 

After insertion of all mooring lines, the Mooring setup should look like the one shown 

in Figure 2-19.  
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Figure 2-19  Vessel View after definition of all mooring lines 

 
Table 2.7 The full Mooring Line definitions 

 

Name Bollard Fairlead Winch 
Line 

profile 

Line 

pretension 

(t) 

Tail profile 
Tail length 

(m) 

Line 1 Bollard 1 Fairlead 1 Winch 1 Steel_wire 5 Nylon_rope 11 

Line 2 Bollard 1 Fairlead 2 Winch 2 Steel_wire 5 Nylon_rope 11 

Line 3 Bollard 3 Fairlead 3 Winch 3 Steel_wire 5 Nylon_rope 11 

Line 4 Bollard 3 Fairlead 4 Winch 4 Steel_wire 5 Nylon_rope 11 

Line 5 Bollard 4 Fairlead 5 Winch 5 Steel_wire 5 Nylon_rope 11 

Line 6 Bollard 4 Fairlead 6 Winch 6 Steel_wire 5 Nylon_rope 11 

Line 7 Bollard 5 Fairlead 7 Winch 7 Steel_wire 5 Nylon_rope 11 

Line 8 Bollard 5 Fairlead 8 Winch 8 Steel_wire 5 Nylon_rope 11 

Line 9 Bollard 7 Fairlead 9 Winch 9 Steel_wire 5 Nylon_rope 11 

Line 10 Bollard 7 Fairlead 10 Winch 10 Steel_wire 5 Nylon_rope 11 

Line 11 Bollard 8 Fairlead 11 Winch 11 Steel_wire 5 Nylon_rope 11 

Line 12 Bollard 8 Fairlead 12 Winch 12 Steel_wire 5 Nylon_rope 11 
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To complete the mooring line definitions, go to the Mooring line data tab and set the 

Line profile, Line pretension, Tail profile and Tail length values for all the Mooring 

lines (Line 1 – Line 12) according to the values shown in Table 2.7.  

 

16. Dialog: Physical Parameters 

In this dialog, you should use the default values: 

- Density of water = 1020  [kg/m3] 

- Density of air = 1.28  [kg/m3] 

- Viscosity (water) = 10-6  [m2/s] 

- Viscosity (air) = 1.48 • 10-5  [m2/s] 

 

17. Dialog: Drift Forces 

Drift forces are not included. 

 

18. Dialog: Current 

Do not include a current field. 

 

19. Dialog: Wind 

Do not include a wind field. 

 

20. Dialog: Convergence Parameters 

In this dialog, you should specify the following values: 

- Max no. of iterations = 1000 

- Line convergence threshold = 0.1 % 

 

21. Dialog: Vessel Displacements 

Apply default parameters. 

 

22. Dialog: Convergence Output 

Apply the default output file names. All output files except ‘External forces’ and 

‘Chain forces’ are included. 

 

Ensure that all data in the (.m21ma) setup are saved.  

2.8 Step 8 – Run the simulation in Convergence Mode and inspect results 

To execute the setup in Convergence Mode, click: 

 

Run → Start simulation … → Click OK in the Launch settings’ pop-up window 

 

As you will see, the simulation converges within the specified number of iterations. 

 

Open the output file ‘Convergence_line_pretension_deviation.dfs0’. As you can see, the 

percentage deviations between the line tensions and the line-pretension are all less than 

the specified line convergence threshold of 0.1 % for all lines, at the final iteration. 

 

This means that the spatial vessel state (Surge, Sway, Heave, Roll, Pitch, Yaw) at the 

final iteration in file ‘Convergence_DHI_Vessel_motions.dfs0’ is a reasonable initial vessel 

displacement, within the chosen line convergence threshold of 0.1 %, to launch the final 

time-domain computation with. 

 

With this initial vessel displacement known, we can move on with the final time-domain 

computation. 
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2.9 Step 9 – Create a Wave File 

Before continuing with final time-domain simulation in M21 MA, we will have to create the 

time series wave file to be used as the primary forcing in this example.  

 

1. Go to MIKE Zero and Click on ‘New File’. 

2. Under ‘MIKE 21’ select ‘MIKE 21 Toolbox (.21t)’. 

 
 
Figure 2-20 Location of MIKE 21 Toolbox 

 

3. Expand the ‘Waves’ Selection and double click on ‘Random Wave Generation’. 

 
 
Figure 2-21 MIKE 21 Toolbox: Random Wave Generation 
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4. Create a new Setup called ‘M21 MA – 0D Wave’. 

5. Select the JONSWAP spectrum with the following parameters significant wave height 

(Hm0) 1m and peak wave period (Tp) 10 s. 

6. Set the water depth to 15 m. 

7. Set the smallest wave period in series to 1 s. 

8. Select ‘Enable Second Order Correction’.  

9. Specify the Start date as: 01/01/2016 00:00:00 and ‘Number of time steps’ as 4500 

and interval as 1 s. 

10. Save the file at the following location:  

<example installation folder>\ MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing 

\Inputs\Metocean_timeseries\Hm0_1m_tp10s.dfs0 

 

11. Click on ‘Execute’ to run. 

12. At successful completion, a pop up box saying ‘Status: OK’: will show up. Click ‘OK’ 

and ‘Finish’ and Save the setup as ‘M21 MA -0D Wave.21t’. 

13. Open the .dfs0 that was created entitled Hm0_1m_tp10s.dfs0 and delete all the 

items except the Surface Elevation item. 

14. Create a zero warmup period of roughly 15 minutes: 

a. Go to time steps 0 and 875 and set the surface elevation values to 0. 

b. Delete all values between time steps from (and including) 1 – 874 

c. Select all values from (and including) 0 and time step 875.  

d. Click on ‘Tools’ →’Interpolation’. Click ‘OK’ 

The final surface elevation time series are shown in Figure 2-23. 

 

 
 
Figure 2-22 Interpolation feature from the time series (.dfs0) editor 
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Figure 2-23 Water Surface Elevation time series with a zero warmup period 

 

 

15. Next, insert a new wave direction item in front of the existing Surface Elevation item 

by following these steps:   

a. Click Edit → Properties …  

b. Mark the Surface Elevation item record by left-clicking on the record 1 field, so 

the whole record is highlighted (black) 

c. Click Insert to open a new first item and give this new item the name ‘Wave 

direction’ 

d. Select Type = Wave direction and set Unit to degree.  

e. Click OK. 

 

16. The wave direction in a time series wave file to be used in M21 MA must be provided 

constant per individual (wave direction, surface elevation) wave pair. Set the wave 

direction uniformly to 120 [deg] (eg. wave is coming from 120 [deg] True North) by 

following these steps: 

a. Put a value of 120 [deg] at first time step (0) for the wave direction item 

b. Put a value of 120 [deg] at last time step (4499) for the wave direction item 

c. Highlight the whole wave direction column and click on ‘Tools’ →’Interpolation’. 

Click ‘OK’ 

The wave direction is now uniformly set to 120 [deg] for the single wave pair (wave 

dir., surface elevation) used in this example.  
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2.10 Step 10 – Populate the M21 MA Setup with Final Execution Mode Data 

1. Dialog: Time 

Here you specify the temporal conditions applying for the time-domain computation 

(simulation mode = final computation mode).  

 

Make the following: 

a. Set the No. of timesteps to 17995 

b. Set the timestep interval to 0.25 [s] 

c. Set the simulation start date to 01-01-2016 00:00:00 

d. Set the No. of warm up time steps to 0 

 

2. Set the No. of warm down time steps to 0Dialog: Simulation Mode 

In the setup ‘Mooring setup .m21ma’, go to the Simulation mode dialog and switch 

from Convergence Mode to Final Computation Mode. Check the number of timesteps 

in the Time instance as you might have used fewer timesteps in the convergence 

mode than required in the final computation mode. 

 

This will open the Wave dialog, which is specific for this mode: 

 

3. Dialog: Wave 

In this dialog you should do the following:  

a. Select Wave type = Wave field 

b. Uncheck ‘Include warm up/down’ 

c. Select Format = Varying in time, constant in domain 

d. Set Number of waves to 1 

Set Power (N) to 12 (leading to FFT size = 4096)  

Finally, select the wave file, which was created earlier: 

<example installation folder>\ MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave 

Forcing\Inputs\Metocean_timeseries\Hm0_1m_tp10s.dfs0 

 

4. Dialog: Vessel Displacements 

In this dialog you should by now see an enabled Load button. 

 

Click on the Load button. This will populate the 6 Initial Vessel displacement fields 

(Surge, Sway, Heave, Roll, Pitch, Yaw) with the data from the final iteration of the 

output file ‘Convergence_DHI_Vessel_motions.dfs0’ we previously produced from 

the convergence mode execution. 

 

This action ensures the final time-domain computation starts from a vessel state 

where there is a sufficient state of tensional equilibrium in all mooring lines. 

 

5. Dialog: Final output 

Leave the output file settings as default. All output files except ‘External forces’ and 

’Chain forces’ are included. 

 

Set the vessel motion type to ‘Relative to displaced position’. 

2.11 Step 11 – Run the Final Time-domain Simulation and Inspect Results 

To execute the (.m21ma) setup in Final Computation Mode, click: 
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Run → Start simulation … → Click OK in the Launch settings’ pop-up window. 

 

The simulation will be fast and produce the relevant output files for the time-domain 

analysis. 

 

First thing to consider is the Operability Summaries for Lines and Fenders at the end of 

the simulation frame as shown in Figure 2-24. Note that you can find the information at 

the end of the (.log) file produced by the engine as well. For this simulation the critical 

bollard loads, line loads and critical compressions were never exceeded, indicating the 

mooring system dynamics is within the provided safety limits. 

 

 
 
Figure 2-24 Operability Summaries for Bollards from the engines .log file. Scroll up for more 

information on Lines and Fenders. 

 

The following steps will outline how to plot the results of three vessel motions (surge, 

sway and roll) acting on the vessel. 

 

1. Go to the result files folder below: 

(<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Setups\Mooring 

setup.m21ma - Result Files). 

Open the file ‘DHI_Vessel_motions.dfs0’.  

 

2. Create a new plot composer (.plc) file. Open a new MIKE Zero file. Click on ‘New’ → 

Plot Composer (.plc). 

3. Create a new .plc file with three subplots,  

4. Go to ‘Plot’ → ‘Insert New Plot Object’. Select ‘Multiple Plots Tiled’ and set nx to 1 

and ny to 3. Select ‘Time Series Plot’ and click OK. 

5. For the first plot window: Mark the window, right click, click Properties… 
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6. Click on ‘New Item’, cf. Figure 2-25. 

 

 
 
Figure 2-25 Add new time series to plc plot 

 

7. Link to the time series file: 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing\Setups\Mooring 

setup - 0D wave forcing.m21ma - Result Files\ DHI_Vessel_motions.dfs0’ 

 

8. Select item 1 – ‘Surge’ 

 

9. A plot of surge will appear in the first window.  

 

10. Repeat the steps 6-9 for the remaining 2 windows and plot items: sway and roll (from 

output file: DHI_Vessel_motions.dfs0). The final plots are shown in Figure 2-26. 
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Figure 2-26 Time series of vessel motions 

 
  



Example: 0D Wave Forcing on a Vessel  

 29 

2.12 Step 12 – Visualise Vessel Movements in 3D 

It is possible to visualise the vessel movements by using MIKE Animator Plus.  

MIKE Animator Plus is a digital video production studio which enables you to turn e.g. 

MIKE 21 model results into 3D video presentations.  

 

The results from the MIKE 21 Mooring Analysis module include a time series file with 

vessel motions. By using information from this together with a 3D solid representing the 

vessel, and data files with bathymetry and time-varying water level it is possible to use 

MIKE Animator Plus to create an informative animation of the vessel movements for the 

given mooring situation. 

 

The following sections describe how to setup MIKE Animator Plus to visualise the findings 

from the MIKE 21 Mooring Analysis model.  

Note that you can still visualise the data if you do not have a license for MIKE Animator 

Plus, however in that case a DHI icon will be displayed in front in the graphics window. 

 

All references to file locations in the following are given with reference to the top folder  

.\MIKE_21\Maritime\MooringAnalysis\0D Wave Forcing. 

2.12.1 Generate input files for MIKE Animator Plus 

Before opening MIKE Animator Plus you must ensure the input data files fits the purpose. 

This example only displays the results for 10 minutes from the end of the simulation. 

Bathymetry 

The bathymetry is already defined in the file .\Inputs\Domain\Domain.dfs2. 

For better overview in the MIKE Animator Plus setup, copy the file to the folder dedicated 

the MIKE Animator Plus setup: .\MAPlus\Domain.dfs2. 

Surface elevation 

The surface elevation in the mooring analysis simulation was specified as a dfs0 file, 

however this information needs to be represented by a dfs2 file in MIKE Animator Plus. 

In order to reduce the size of the dfs2 file holding the water levels over time first a coarse 

grid version of the bathymetry is created:  

 

1. Go to MIKE Zero and Click on ‘New File’ 

2. Under ‘MIKE Zero’ select ‘MIKE Zero Toolbox’ 

3. Expand the ‘Transformation’ section and double click on ‘Rotate Grid’ 
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Figure 2-27 MIKE Zero Toolbox: Rotate Grid 

 

4. Create a new setup called ‘Coarse Bathy’ 

5. Select the input bathymetry file Domain.dfs2 mentioned above 

6. Accept the subseries selection 

7. Select item as ‘Scalar’ 

8. Define a new grid with 9 grid points in the X direction and 2 grid points in the Y 

direction, both with grid spacing 40 m. The relative origin is set to (0,0) cells and the 

rotation angle to 0 deg. 

9. Define Land-water interpolation option to ‘Data is bathymetry data’ and set minimum 

land value to 2 m.  

10. Save the resulting dfs2 file in the following location: \MAPlus\CoarseDomain.dfs2  

11. Click on ‘Execute’ to run. 

12. At successful completion, a pop up box saying ‘Status OK!’ will show up. Click ‘OK* 

and ‘Finish’ and save the setup as ‘GenerateTSData.mzt’. 

Next the water levels from the input dfs0 file must be populated into a coarse grid file. 

 

1. In MIKE Zero open the MIKE Zero Toolbox file ‘GenerateTSData.mzt’ (if closed)  

2. Expand the ‘Time Series’ section and double click on ‘Preprocessing Temporal Data’ 
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Figure 2-28 MIKE Zero Toolbox: Preprocessing Temporal Data 

 

3. Create a new setup called ‘Waterlevel 2D’ 

4. Select to import station location ‘From x,y,name file’ and select the existing file 

.\Inputs\Port Data\Fenders.xyz.  

5. Set the Projection to ‘Local Coordinates’ and press ‘Import stations’. 

6. Highlight the second row and press the ‘Delete’ button (only one point in the Domain 

is needed) 

7. Press the ‘…’ button in the remaining row and select the second item (‘Surface 

elevation) from the previously generated time series file 

.\Inputs\Metocean_timeseries\Hm0_1m_tp10s.dfs0 

8. Press Next and accept default calculation method. Press Next. 

9. For Model output select ‘Spatially and temporally distributed data’. Define the static 

model area by ‘dfs2 file’ and select the previously generated coarse bathymetry file 

.\MAPlus\CoarseDomain.dfs2  

10. Save the output file name at the following location: .\MAPlus\Waterlevel_2D.dfs2. 

Define the ‘Item name’ as ‘Water level’ 

11. Define ‘Start time’ as 01/01/2016 01:00:00 and ‘End time’ as 01/01/2016 01:10:00. 

Set the ‘Time step in output’ as 1 second. 

12. The Overview will show the position of the station in the domain 
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13. Click on ‘Execute’ to run. 

14. At successful completion, a pop up box saying ‘Finished successfully!’ will show up. 

Click ‘OK* and ‘Finish’ and save the setup. 

Vessel movements 

In order to visualise the movements of the vessel in MIKE Animator Plus a 3Dsolid (.3ds) 

can be linked to a trajectory file. In this example the 3Dsolid Container.3ds is selected as 

a representative for the vessel. 

 

 
Figure 2-29 Container.3ds as displayed in MIKE Animator Plus.  

The cross shows the origin of the 3D solid in its local coordinate system  

 

The MIKE 21 Mooring Analysis simulation creates an output file with resulting vessel 

movements relative to the origin (0,0). As the selected 3D solid is defined with a local Z-

level origin at the bottom of the ship, it is necessary to modify the vessel motion values to 

position the vessel correctly with the water level. Also, the item descriptions need to be 

modified in order to meet the standard for trajectory files in MIKE Animator Plus. For 

simplicity the time step in the file is modified to match the water level, i.e. 1 second. 

 

1. In MIKE Zero open the MIKE Zero Toolbox file ‘GenerateTSData.mzt’ (if closed)  

2. Expand the ‘Time Series’ section and double click on ‘Interpolate Time Series’ 
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Figure 2-30 MIKE Zero Toolbox: Interpolating Time Series 

 

3. Create a new setup called ‘MAPlus Trajectory file’ 

4. Select the output file .\Setups\Final Mooring setup - 0D wave forcing.m21ma - Result 

Files\DHI_Vessel_motions.dfs0’ and select all six items in the file. Press OK and 

Next. 

5. Define ‘Start time’ as 01/01/2016 01:00:00 and ‘End time’ as 01/01/2016 01:10:00. 

Set the time Interval to 1 second. Press Next 

6. Specify the new output file as .\MAPlus\DHI_Vessel_motions_MAPlus.dfs0 

7. Press next and click on ‘Execute’ to run. 

8. At successful completion, a pop up box saying ‘Interpolation succeeded’ will show 

up. Click ‘OK* and ‘Finish’ and save the setup. 

Now it is necessary to modify the dfs0 file to match the requirements for this MIKE 

Animator Plus setup. 

 

1. Open DHI_Vessel_motions_MAPlus.dfs0 in Time Series Editor 

2. Subtract 9.8 m from the third item (Heave) to account for the Draft of the vessel (as 

defined in Table 2.1), see Figure 2-31. Press OK and save and close the file 

‘GenerateTSData.mzt’. 
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Figure 2-31 Modifying position of vessel to accommodate local coordinate system of 3Dsolid.  

 

3. Change the item descriptions to meet MIKE Animator Plus requirements as follows:  

a. Click Edit → Properties …  

b. Change  item type for item 1 (Surge) to be ‘Geographical coordinate’ 

c. Change  item type for item 2 (Sway) to be ‘Geographical coordinate’ 

d. Change  item type for item 3 (Heave) to be ‘Item geometry 3-dimensional’ 

e. Leave item types for item 4 to item 6 as is (Angles) 

f. Click OK and save file. 

 

  
 
Figure 2-32 Valid item descriptions in trajectory file for MIKE Animator Plus  
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2.12.2 Create a MIKE Animator Plus setup 

The set of steps below outline how to create a new MIKE Animator Plus setup. 

The first task is to create a setup to display the initial conditions. After that the MIKE 

Animator Plus setup can be extended to make an animation by including time varying 

data.  

Initial conditions 

1. Open the MIKE Animator Plus editor. It can be located by searching for it in the 

Windows start menu. 

2. Click ‘File’ → ‘Insert’ → ‘Scene’ and select the domain bathymetry file 

.\MAPlus\Domain.dfs2 

3. Highlight ‘MIKE 21 file – Domain.dfs2’ in the property tree and double-click 

‘Bathymetry’ to select to show bathymetry 

 
 
Figure 2-33 Inserting and selecting bathymetry data in MIKE Animator Plus  

 

4. Click on ‘Scene’ and select the ‘Fill’ tab. Click on ‘Fountain fill’ to change the colour of 

the background. 

5. ‘Select Scene mode’ in the toolbar as shown in Figure 2-34 and change the 

viewpoint by click-and-drag in the graphics window. 

. 
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Figure 2-34 View of domain bathymetry after changing the fill colour and viewpoint  

 

6. Click ‘File’ → ‘Save Layout’ and save the setup to the new file 

.\MAPlus\Vessel_motions.lyt 

 

7. Right-click ‘Scene’ and select ‘Load data..’ 

 

 
 
Figure 2-35 Adding data to existing scene  
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8. Select the file .\MAPlus\Waterlevel_2D.dfs2 and double-click the ‘Water level’ 

variable to display the item data in the graphics window 

9. In the ‘Surface’ tab uncheck ‘Mulit-color’ and select ‘Smooth’ surface 

10. Finally click the ‘Color’ button and change the Alpha value from 255 to 155 to include 

transparency of the water surface 

  

 
 
Figure 2-36 Transparent water level in the graphics window  

 

11. Click ‘File’ → ‘Save Layout’ and save the setup 

12. Right-click ‘Scene’ and select ‘Load data..’ 

13. Select the 3Dsolids file .\MAPlus\Container.3ds and double-click the ‘Solids Model’ 

variable to display the solids file  in the graphics window 

14. Now scale the Solids Model to resemble the outline of the vessel used in the Mooring 

Analysis simulations. Set the variables as follows:  

a. Uncheck ‘Uniform Scaling’ 

b. Set X extent to 223.8 m 

c. Set Y extent to 32.4 m 

Set Z extent to 35.6 m (twice the deck height)  

15. To position the Solids Model correctly in the vertical for the initial time step, go to the 

‘Solids’ tab and change the translation in the Z-domain to -9.8 m. 

16. Click ‘Objects’ in the tree and change the Drawing order so the Water level is the last 

item drawn. 
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Figure 2-37 View of Solids Model after scaling and repositioning from default values 

 

17. Click ‘File’ → ‘Save Layout’ and save the setup 

Animation 

1. Click ‘Insert’ → ‘Clock’ to add a clock to the graphics window 

2. Click the ‘Select Layout mode’ icon in the toolbar 
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Figure 2-38 Initial view of Clock object in graphics view 

 

3. In the ‘Fill’ tab un-check ‘Solid fill’ 

4. Click-and-drag the Clock object in the graphics-window to a position in the upper left 

corner 

5. In the ‘Clock’ tab select the Source Figure to be ‘Figure 1  Scene’ and the Source 

File to be ‘File 2 – MIKE 21 file – Waterlevel_2D.dfs2’ 

(Now the clock will indicate the time stamp in the file while the animation is running)  

6. Click the ‘Play’ button to watch the water level change in time 
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Figure 2-39 Animating time-varying water level with clock showing instant time step 

 

7. Next click the Solids Model Object and select the ‘Trajectory’ tab. 

8. Define the Movement to ‘6 parameters’ and select the Source file 

.\MAPlus\DHI_Vessel_motions_MAPlus.dfs0 

 
 
Figure 2-40 Specifying data file for vessel movement 
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9. Click the ‘Play’ button to watch the vessel move and water level change in time 

10. Click ‘File’ → ‘Save Layout’ and save the setup 

11. Click Scene mode to rotate and position the domain to get the optimal view for you 

12. Save the animation by clicking the ‘Animate’ button in the toolbar below the graphics 

window. 

13. Save the file as e.g. Vessel_Motions.avi. 

14. While the model records the animation the graphics window will be greyed out, and a 

progress bar appear in a new window. 

 

 
 
Figure 2-41 Recording animation of vessel movement 

 

15. When the recording is done click ‘Close’. 

16. The resulting animation file Vessel_Motions.avi can now be shown in e.g. Windows 

Media Player as shown in Figure 2-42. 
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Figure 2-42 Recorded animation as shown in Windows Media Player 
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3 Example: 2D Wave Forcing (Port of Brisbane, Passing Vessel 
Induced Moored Vessel Motions) 

This example is based on a scenario from the 2009 validation of physical model tests of 

passing vessel induced moored vessel interaction carried out for the Port of Brisbane, 

Australia presented in Mortensen et al (2009). The example files present a simplified 

version of the numerical validation. 

 

The example consists of a passing vessel scenario where moored ship motions induced 

by the passing of a 47,000 m3 tanker were investigated at the Shell Berth in the Upper 

Lytton Reach of the Brisbane River.  

 

This tutorial consists of three major sections: 

 

1. Creating a passing vessel induced pressure field  

2. Running a MIKE 21 FM simulation to calculate passing vessel induced displacement 

waves  

3. Utilisation of the calculated displacement wave in M21 MA in order to calculate 

moored vessel motions, line and fender forces as a result of the passing vessel 

induced displacement waves.  

3.1 Launch Frequency Response Calculator 

As per Section 2.1, the first step in this analysis is to create an FRC setup to calculate the 

frequency determined response of the vessel.   

 

1. Create a new instance of the (.fresponse) editor or open the file 

DHI_Tanker.fresponse in the folder <example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave Forcing\FRC\Setup 

 

2. In the Vessel Configuration Dialog select the grid 1-3DHI.grd located here: 

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\FRC\Inputs\VesselGrid\1-3DHI.grd 

 

3. Set the water depth to 13.2m and Density of water to 1024.61 [kg/m3] 

 

4. Click on the ‘plus’ symbol  to open the Vessel 1 tab. Under Vessel 

Characteristics, enter the following parameter values 
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Table 3.1 Vessel Characteristics - Vessel 1 

 

Parameter Value Unit  

Vessel Scaling (X-Dim)  1 dimensionless  

Vessel Scaling (Y-Dim) 1 dimensionless  

Vessel Scaling (Z-Dim) 1 dimensionless  

rxx 7.38 [m]  

ryy 46 [m]  

rzz 46 [m]  

Vertical Center of Gravity (ZG) 10 [m] Relative to vessel keel  

Draft 10 [m] Relative to vessel keel 

Deck plane height 14 [m] Relative to vessel keel 

 

5. Under Freedom of motion, set the freedom of motion to freely floating. 

Dialog: Computational Settings 
6. Set Simulation Mode to : M21 Mooring Analysis compatible mode 

 

7. Set Number of frequencies to solve to 512  

 

Dialog: Wave Drift Forces 
8. Ensure that Wave drift forces box is unticked.  This is not necessary for this example 

 

 
 
Figure 3-1 Wave drift forces checkbox 

 

Dialog: Outputs 
9. Ensure that the Vessel Response checkbox is ticked. This will output the .vre  file 

required for the M21 MA simulation. 

 

10. You may also wish to check the other boxes however, they are not essential for this 

example. 

 

11. Run the simulation. 
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3.2 Prerequisite Tasks 

Prerequisite Task 1 – Create vessel track  

The first prerequisite task is to create the trajectory of the passing vessel and associated 

track boundaries for inclusion into the HD mesh. The track should comprise a sequence 

of coordinates of the centre of the vessel at each point in time and should be in a dfs0 

format (equidistant calendar axis). 

 

Note: The standard MIKE Zero time series editor only supports single precision for items, 

thus it can at times be necessary to represent the sail route coordinates in double 

precision, dependent on the associated projection. Double precision for items in a dfs0 

time series file can be set through usage of the Time Series Package, which is available 

as a free, non-licensed download.  

 

The general steps for putting a sail route into a dfs0 file in double precision are provided 

below: 

 

1. Create a new dfs0 file, with the standard time series (.dfs0) editor – save the file as 

TrackCentre_8knots.dfs0. Include 2 items, name them ‘Easting’ and ‘Northing’ and 

set item type for both to ‘Geographical coordinate’ and provide the relevant start date 

and number of time steps. 

 

Go to the MIKE installation directory …DHI\2020\bin\x64. 

 

2. Double-click on TSEditor.exe to run the Time Series Editor. 

 

3. Click File - > Open -> Select dfs Timeseries Bridge and click OK. Now open file 

TrackCentre_8knots.dfs0 

4. Set the precision of both Easting and Northing items to double precision, by doing 

this for each item: 

- Mark the item. 

- Right click -> Item Properties … 

- On the item properties dialog, select Data Type = Type_Double and click OK 

- Save the file 

 

 
 
Figure 3-2 Time Series Editor – Change item Type 

http://mikepoweredbydhi.com/
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5. Finally populate the Easting and Northing columns with the data values representing 

the sail route, and save the file: 

You now have a file TrackCentre_8knots.dfs0 with the Easting, Northing coordinates 

stored in double precision. 

 

For the purposes of this example, a double precision version of the specific vessel track 

file is provided here:  

 

<example installation folder>\MIKE Zero Projects\MIKE_21\Maritime\MooringAnalysis\2D 

Wave Forcing\HD\PassingVessel\TrackCentre_8knots.dfs0 

 

Prerequisite Task 2 – Create HD mesh 

Prior to creating a moving pressure field of the passing vessel, it is essential to first create 

a mesh on which the vessel will be positioned at each time step. For the purpose of this 

step-by-step guide, a mesh file comprising the berth pocket and adjacent passing vessel 

trajectory has been provided here: 

 

<example installation folder>\MIKE Zero Projects\MIKE_21\Maritime\MooringAnalysis\2D 

Wave Forcing\HD\Bathy\2DExample_Mesh.mesh 

 

The mesh was developed using a simplified, constant bathymetry, however, the 

complexity of the mesh layout was retained to provide an example of typical mesh 

requirements for such a passing vessel analysis. 

 

The mesh is made up of three primary element types: 

 

1. Coarse resolution triangular elements – away from the moored vessel 

2. High resolution triangular elements – in the vicinity of the moored vessel 

3. Quadrilateral mesh – along the length of the vessel track 

 

In order to prevent shock waves occurring from the introduction of the passing vessel into 
the model domain, it is recommended that the vessel track is created such that it extends 
well past the vessel, on either end. The quad mesh must be long enough to cover the 
entire vessel track. This is due to the fact that the engine for creation of the moving 
pressure field of the passing vessel, only supports a sail route which goes through quad 
mesh regions. 
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Figure 3-3 Extract from Port of Brisbane mesh showing the coarse mesh resolution further afield, high resolution in 

the vicinity of the moored vessel (visualised with graphics at the bottom of the plot), and quadrilateral mesh 
along the trajectory of the passing vessel 

 

Instructions for mesh creation 

This step by step guide does not provide detailed information on mesh creation, however, 

this is covered in the MIKE 21 HD FM manual.  

 

To access this document go to: 

• Start Menu -> Search for 'MIKE Zero Documentation Index'. The document will open 

in a web browser. 

• From here, select MIKE 21 Documentation  → MIKE 21 Flow Model FM →MIKE 21 

& MIKE 3 Flow Model FM, Hydrodynamic Module, Step-by-Step, Training Guide 
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3.3 Create the Moving Pressure Field of the Passing Vessel 

With the time series of the vessel position (vessel track) and mesh created, the next step 

is to create the moving pressure field. 

 

For the purpose of modelling moving vessel induced displacement waves in MIKE 21 FM, 

the moving vessel can be represented by either a moving pressure field or a moving block 

of ice. In this tutorial the moving vessel will be represented by a moving pressure field. 

The moving pressure field for the passing vessel will be obtained through usage of a 

numerical engine in the MIKE installation PassingVessel.exe which as input requires a 

sail route trajectory in (.dfs0) format, a domain mesh (.mesh) and a panelised 3D vessel 

hull (.grd) file.  

 

The first stage of the processing in the engine PassingVessel.exe will interpolate the 3D 

vessel hull onto a 3D stencil as illustrated in Figure 3-4. It should be noted that although 

the overall 3D shape of the vessel is well preserved, features such as the submerged part 

of the stern or bulb keel may be only partly represented.  

 

A spatially and temporally varying pressure field is used to simulate the displacement of 

water caused by the moving vessel. The pressure field is generated from the vessel grid 

file containing the hull 3D geometry data, which is then interpolated to a 2D stencil in a 

dfsu format. Subsequently a pressure field representing the moving stencil is interpolated 

onto the mesh, with the vessel position’s changing according to the pre-defined vessel 

track (the dfs0 based sail route trajectory).  

 

 
 
Figure 3-4 WSE around the passing vessel. (Note: The vessel track is at a slight angle in this example) 

 

In its current form, the Passing Vessel engine is a stand-alone engine without a user 

interface. So the engine can currently only be executed from the command line (batch 

mode). The steps below show how to run the Passing Vessel engine against the 

compatible input file (.m21pv) in batch mode by using a (.bat) file. 

 

Follow the steps below to create the moving pressure field of the passing vessel: 

 

1. Go to the folder  

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave Forcing\HD\PassingVessel 

 

2. Open the file TrackCentre_8knots_1-3DHI.m21pv with a text editor such as 

Notepad or Textpad. You will see that there are 7 main PFS sections in this file:  

- [ DOMAIN ] 

- [ VESSEL ] 
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- [ SIMULATION_TIME ] 

- [ VESSEL_TRAJECTORY_DATA ] 

- [ PHYSICAL_DATA ] 

- [ COMPUTATIONAL_SETTINGS ] 

- [ OUTPUT ] 

 

Dialog: Domain  
3. Link to the file 2DExample_Mesh.mesh as below 

 
[DOMAIN] 

   file_name = |..\Bathy\2DExample_Mesh.mesh| 

EndSect  // DOMAIN 

 

Dialog: Vessel 
4. Link to the file 1-3DHI.grd and set the scaling parameters as below 

 
[VESSEL] 

   vessel_grid = |.\1-3DHI.grd| 

   draft = 10 

   [VESSEL_SCALING] 

      x = 0.999 

      y = 1.038 

      z = 1 

EndSect  // VESSEL_SCALING   

 

Dialog: Simulation Time  

5. Set the start_time to 2011, 2, 27, 10, 0, 0 

6. Set the number_of_timesteps to 540 

7. Set the time_step_size to 1 

 
[SIMULATION_TIME] 

   start_time = 2011, 2, 27, 10, 0, 0  

   number_of_time_steps = 540  

   time_step_size = 1  

EndSect // SIMULATION_TIME 

 

Dialog: Vessel Trajectory Data 
8. Set type to 0.  This is currently the only mode supported in the passing vessel engine 

and is based on a dfs0 file (Equidistant calendar axis) containing 2 items which 

represents the sail route trajectory of the centre point of the vessel at each time step, 

with equidistant time steps.  To check that the dfs0 has the correct format, open the 

dfs0 file and go to File →Edit →Properties and check that settings are as shown 

below. 
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Figure 3-5 Properties of input vessel track dfs0 file 

 

9. Ensure that the projection is set to MGA-56.  

10. Link the vessel_ file to the time series of vessel position - TrackCentre_8knots.dfs0 

11. Set items = 1, 2 

 

[VESSEL_TRAJECTORY_DATA] 

   type = 0        

 projection = 'PROJCS["MGA-56",GEOGCS["Unused",DATUM["Australian 

Datum",SPHEROID["Geodetic Reference System 

1980",6378137,298.257222101]],PRIMEM["Greenwich",0],UNIT["Degree",0.01

74532925199433]],PROJECTION["Transverse_Mercator"],PARAMETER["False_Ea

sting",500000],PARAMETER["False_Northing",10000000],PARAMETER["Central

_Meridian",153],PARAMETER["Scale_Factor",0.9996],PARAMETER["Latitude_O

f_Origin",0],UNIT["Meter",1]]'    

   vessel_file = |.\TrackCentre_8knots.dfs0|   

   items = 1, 2           

EndSect  // VESSEL_TRAJECTORY_DATA 

 

Note: The map projection string above must be obtained manually. The general and 

easiest way to obtain map projection strings is as follows:  

• Open up a MIKE Zero window  

• Under New File, select Mesh Generator (mdf) 

• Under the dropdown list that appears, select the map projection that you would like to 

use and save the file 

• Load the newly created .mdf file in a text editor 

• Scroll to the section [MESH_DATA]. Under the item UTMZone you will see the 

projection string required for the passing vessel input file, which can now be copy-

pasted. 
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Dialog: Physical Data 

12. Set gravity_constant to 9.81 

13. Set ambient_pressure to 1013.0 

14. Set density_type to 1 - Set to 1 to define a density value or 2 to derive from the 

temperature & salinity values 

15. Set rho to 1024.61 

 

If density_type is set to 2 then desired temperature and salinity values must be specified 

 
[PHYSICAL_DATA] 

   gravity_constant = 9.81 

   ambient_pressure = 1013.0 

   density_type = 1  

   rho = 1024.61  

   temperature = 10.0  

   salinity = 32.0  

EndSect // PHYSICAL_DATA 

 

Dialog: Computational Settings 

16. Set mesh_x_resolution to 0.1 [m] 

17. Set mesh_y_resolution to 0.1 [m] 

18. Set interpolation_threshold to 0.05 

19. Set include_max_pressure_difference to 0 

20. Set include_soft_start_duration to 0 

 
[COMPUTATIONAL_SETTINGS] 

   mesh_x_resolution = 0.1 

   mesh_y_resolution = 0.1 

   interpolation_threshold = 0.05 

   include_max_pressure_difference = 0  

   max_pressure_difference = 3 

   include_soft_start_duration = 0  

   soft_start_duration = 30.0 

EndSect // COMPUTATIONAL_SETTINGS 

 

Dialog :Output 
The following default outputs are specified: 

 

• Vessel_pressure_field.dfsu – this file represents the moving pressure field of the 

passing vessel and contains three items: Wind X, Wind Y and Pressure 

• Global_initial_WL.dfsu - water level file of the initial position of the moving vessel 

(used as initial condition in MIKE 21) 

• Vessel_orientation.dfs0 – The engine produces a timeseries (dfs0) file showing a 

time-series of the first order time derivative of the vessel azimuth. The curve is a 

quantification of the magnitude of the rotation of the vessel in each time step. The 

value should be less than at least 10-3 in order to avoid shockwaves in the MIKE 21 

simulations.   

• Vessel_log.dfs0 

• Local_Vessel_WL.dfs2 
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[OUTPUT] 

   [MOVING_PRESSURE_FIELD]  

      file_name = 'Vessel_pressure_field.dfsu'  

   EndSect // MOVING_PRESSURE_FIELD 

   [INITIAL_WATER_LEVEL]  

      file_name = 'Global_initial_WL.dfsu'  

   EndSect // INITIAL_WATER_LEVEL 

   [VESSEL_ORIENTATION]  

      include = 1 

      file_name = 'Vessel_orientation.dfs0'  

   EndSect // VESSEL_ORIENTATION 

   [VESSEL_LOG]  

      file_name = 'Vessel_log.dfs0'  

   EndSect // VESSEL_LOG 

   [LOCAL_VESSEL_WATER_LEVEL]  

      include = 1 

      file_name = 'Local_Vessel_WL.dfs2'  

   EndSect // LOCAL_VESSEL_WATER_LEVEL 

   [SOFT_START]  

      include = 1 

      file_name = 'Vessel_pressure_field_soft_start.dfsu'  

   EndSect // SOFT_START 

EndSect // OUTPUT 

 

The passing vessel input file is now complete and the passing vessel simulation is 

ready to be run. 

 

Steps (continued)  

21. Double click on the .bat file Run Passing Vessel.bat, located here: 

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\HD\PassingVessel\Run Passing Vessel.bat 

 

The following window will pop up, dynamically updating the remaining time for 

completion of the simulation. Once the simulation is completed, a log file will be 

generated, with details of the simulation. The output files listed above will be located 

in the results folder.  

 

 
 
Figure 3-6 Passing Vessel engine (Passingvessel.exe) - working messages 

 

22. Check that the pressure field generated has three items (Wind X, Wind Y, Pressure). 

The 2 Wind composant items will be 0, whereas the Pressure item will show the 

vessel moving through the pressure field as seen in Figure 3-7 below.  This dfsu file 

will be used in the ensuing HD simulation. 
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Figure 3-7  Vessel Pressure field dfsu - Pressure item 

 

23. Open the Vessel_orientation.dfs0 file and ensure that the values are very small. 

 

 
 
Figure 3-8 Vessel Orientation file. Values should be less than 10-3 to avoid shock waves. 
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3.4 HD Simulation – Create the Displacement Wave 

With the moving pressure field now created, a hydrodynamic (HD) simulation will be 

undertaken to create the displacement wave caused by the passing vessel, which then 

propagates to the adjacent berth pocket and impacts the moored vessel. For the purpose 

of this step-by-step guide, the MIKE 21 FM simulation file 

PassingVessel_Example.m21fm has been provided here: 

 

<example installation folder>\MIKE Zero Projects\MIKE_21_Maritime\MooringAnalysis\2D 

Wave Forcing\HD\Setup\PassingVessel_Example.m21fm 

 

Alternatively, create a new MIKE 21 FM simulation file by opening MIKE Zero -> Click on 

'New' and select 'Flow Model FM (m21fm)', and save the file as 

PassingVessel_Example_Username.m21fm in the folder. 

 

Edit the file according to the following steps. 

 

 
 
Figure 3-9   Creating a new MIKE 21 FM model 

 

1. In the ‘Domain’ window, select the mesh file created earlier. 

2. In the ‘Time’ window set the ‘No. of time steps’ to be equal to the number of time 

steps in the .dfs2 file created by the moving pressure field tool.  

- Set the ‘No. of time steps’ to 539.  

- Set the ‘Time step interval’ to 1 second. 

- Set the ‘Start date’ to 27-02-2011 10:00:00 

3. Save the setup. 

4. Select ‘Higher Order’ scheme for both Time and Space in ‘Solution Technique’. 

Reduce the maximum time step to 1 second. 

5. Deactivate Flood & Dry.  
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6. Select Wind Forcing to be ‘varying in time and domain’ and select the newly created 

moving vessel pressure field dfsu file:  

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\HD\PassingVessel\TrackCentre_8knots_1-3DHI.m21pv - Result 

Files\Vessel_pressure_field.dfsu 

7. Set initial condition as ‘Spatial varying surface elevation’ and select the created initial 

water level file.  

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\HD\PassingVessel\TrackCentre_8knots_1-3DHI.m21pv - Result Files\ 

Global_initial_WL.dfsu 

8. Define Boundaries: 

- Go to ‘Boundary Conditions’. 

- Under Land boundary ensure the Type is set to ‘Land (zero normal velocity)’. 

9. Create a new output called ‘Vessel_Induced_Flux’, which should include a 2D 

extraction of Total water depth, P flux and Q flux for the entire model domain. Under 

the tab Output Specification, Set Field Type to 2D (horizontal) and Output format to 

Area series.  

10. Generate an output called ‘Wave Gauges’. The output section should include a point 

output of surface elevation for the two following points (MGA-56):  

Easting Northing Name 

514327.8 6966882 Wave Gauge 1 

514475.7 6966858 Moored Vessel 

 

11. Click ‘Run’ and start the simulation. 

12. The simulation will generate an output dfsu file called Vessel_Induced_Flux.dfsu 

containing the three selected flux variables. In order to input this data into M21 MA, 

the dfsu file must be converted into a dfs2 file (structured grid file). Go to MIKE Zero 

homepage. Click on ‘New’ → select ‘Grid Series (.dfs3,dfs2)’. 



 MIKE 21 Maritime 

56 Mooring Analysis - © DHI A/S 

 
 
Figure 3-10 Convert dfsu file to dfs2 grid – step 1 

 

13. Double click, select ‘From Dfsu File’ and link to the dfsu created by the MIKE 21 FM 

simulation. 

14. When prompted, input the following parameters. 

Projection MGA-56 

Easting  Origin 514339 

Northing  Origin 6966809 

Rotation 0.067 

Spacing in J-dir. and K-dir 2 m 

No. of grid points J-dir 136 

No. of grid points K-dir 45 

 

15. Click Next until Step 5 then click Finish. This concludes the mapping of data from the 

original (.dfsu) file to a (.dfs2) file with the desired properties. This (dfs2) file now 

contains the flux due to a passing vessel induced wave. 

16. M21 MA uses FFT when calculating the incident wave forcing. In order to capture the 

entire simulation we will use 4096 time steps in the FFT analysis. This is done as 

follows: 

- Make a copy of the newly created dfs2 file.  

- Select Edit->Time Steps and select the first time step.   

- Click the copy radio button and select before.   

- Then type in the number of time steps required to reach 4096 (eg. 3556) and 

press Insert.  

- Save the dfs2 file as ‘Grid1_Extended.dfs2’. 
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3.5 Overview of MIKE 21 Mooring Analysis (MA) Steps 

In order to run the MIKE 21 MA simulation with 2D forcing successfully, a number of steps 

must be followed. These are outlined below and the step by step guide is structured to 

provide the user with an understanding of the sequence and method for undertaking the 

more complex M21 MA simulations, coupled to the usage of other MIKE models.  

 

The ensuing guide is structured as follows: 

1. Prerequisite Task – Access to mooring line and fender profiles 

2. Launch MIKE 21 MA 

3. Specify mooring line and fender profiles  

4. Setup the Mooring System 

5. Specify Environmental Conditions 

6. Run simulation in Convergence mode 

7. Run simulation in Final computation mode 

3.6 Prerequisite Task – Access to Mooring Line and Fender Profiles 

For this example mooring line and fender profiles are given, but for general usage the 

M21 MA includes access to a comprehensive selection of standard mooring lines and 

fenders which the user can select. Mooring line stiffness curves have been digitised from 

OCIMF guidelines (OCIMF, 2008) and fender compression curves were obtained from 

Trelleborg manuals.  

 

Non-standard mooring lines and fenders can if needed be custom-made and included in 

the model as time series (dfs0 – relative item axis) of percentage elongation (mooring 

lines) and compression (fender) as x-axis and percentage of reaction force as item 1. 

 

Figure 3-11 and Figure 3-12 show examples of the line and fender curves supported in 

M21 MA. 

 

 
 
Figure 3-11 Linear Mooring line elongation curve – dfs0 for input into M21 MA 
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Figure 3-12 Trelleborg Supercone Fencer compression curve – dfs0 file for input into M21 MA 

3.7 Launch MIKE 21 MA  

Similar to the Frequency Response Calculator editor (.fresponse), the MIKE 21 Mooring 

Analysis editor (.m21ma) is also found under the Maritime subgroup of MIKE 21. 

 

 
 
Figure 3-13  Location of MIKE 21 Mooring Analysis setup editor 

 

The set of steps below outline how to create a new MIKE 21 Mooring Analysis (M21 MA) 

setup. 

 

1. Open a new instance of the (.m21ma) editor as shown in Figure 2-8, by clicking OK. 

The M21 MA main page (Figure 3-14) should appear on the screen. 
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Figure 3-14 M21 MA main page 

 

2. Load the provided tutorial file: 

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\M21MA\Setup\2D_Example.m21ma 

 

Alternatively 
Start saving the file: Select ‘File’ -> ’Save’ and save the filename in the root folder  

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\M21MA\Setup\2D_Example_username.m21ma 

 

Take care not to overwrite the tutorial file 

 

Dialog: Domain 
In the 2D mode, M21MA displays the vessel within the 2D grid domain so that the user 

can clearly see the position of the ship in the domain where the spatial wave file extent 

applies. The first step is that a (dfs2) grid file comprising the bathymetry of the port/berth 

pocket must be loaded into the ‘Domain’ dialog.  This domain file can be created by 

importing the (.mesh) file from the MIKE 21 FM setup into the mesh generator and 

exporting it as a (.dfsu) file with a Bathymetry item. The resulting (.dfsu) file can then be 

mapped into the (.dfs2) format, with the exact same settings as those we applied when 

mapping the wave file from (.dfsu) to (.dfs2) in Section 3.4. 

 

This domain file will dictate the coordinate projection of the wave (dfs2) file, as in all other 

structured grid based M21 models. The user may then use the ‘Plot extent’ function to plot 

the area in the immediate vicinity of the vessel. 
  



 MIKE 21 Maritime 

60 Mooring Analysis - © DHI A/S 

1. Load the file and apply the custom settings seen in Figure 3-15  

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\M21MA\Inputs\Domain\Domain.dfs2 

 

 

 
 

Figure 3-15 Domain window 

 

We will skip the ‘Time and Simulation mode’ dialogs and return to them once the 

mooring system has been set up. 

3.8 Specify Mooring Line and Fender Profiles 

Dialog: Material Profiles 
1. Click on the tab Line Profiles, click new profile and then click Go to button on the 

table that record appears 

 

 
 

2. This will open up a separate tab for Line 1 where these properties of the mooring line 

profile should be set.  

- Set the Total Breaking Strength to 148 [t] 

- Set the Failure Load to 50 [%] 

- Set the Linear damping coefficient to 0 [kg/s] 

- Set the Quadratic damping coefficient to 0 [kg/m] 
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- Click on the Select button and load the file line curve.dfs0 here: 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\M21MA\Inputs\Material Profiles\line curve.dfs0  

3. Click on Fender Profiles, click new profile and then click on the Go to… button 

 

4. This will open up a separate tab where these properties of the fender profile should 

be set:  

- Set the Max reaction force to 4900 [kN] 

- Set the Max deflection to 1 [m] 

- Set the failure deflection to 100 [%] 

- Fender friction coefficient to 0.45 

- Linear damping coefficient to 0 [kg/s] 

- Fender thickness = 1.5 [m] 

- Click on the Select button and link to the file fender curve.dfs0 here: 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave 

Forcing\M21MA\Inputs\Material Profiles\fender curve.dfs0 

For the purposes of this example, linear mooring line and fender curves have been used. 

 

5. Click on Bollard Profiles, click New profile and then click on the Go to… button 

 

6. This will open a separate tab where these properties of the bollard profile should be 

set: 

- Max. horizontal bollard pull force to 2000 [kN] 

- Max. vertical bollard pull force to 1000 [kN] 

- Max. total pull force to 2500 [kN] 

- Max. vertical line angle to 60 [deg] 

- Safety threshold 75 [%] 

 

Be sure to activate the check boxes to include all these settings in this example. 

Dialog: Vessels 
The Vessels dialog requires the user to select the vessel response file generated with 

FRC and it will subsequently show the involved vessels in the table records. 

 

1. Click on the Vessels dialog 

 

2. Under vessel response file, click on the button and select the (.vre) file created from 

the earlier FRC run. This should be located in the results subfolder here  

 

<example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\2D Wave Forcing\FRC\Setup 

 

From here, click on Go to 

 

3. This will load the Vessel data tab representing the properties of the (to be) moored 

vessel. From here: 

- Set Longitudinal area (wind) to 1200 [m2] 

- Set Transverse area (wind) to195 [m2] 

- Set Lpp to 189.6 [m] 

- Set the Loading condition to 0 [%] 

- Select the vessel class ‘VLCC conventional’ from the following available vessel 

classes in the drop-down list shown below 
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Figure 3-16 Vessel data tab showing available vessel class selection 

 

- Set the Deck plan height to 15 [m] 

4. Go to the Fairlead data tab. Copy and paste the following values into the fairleads 

table. Note: This data can also be loaded into the table if available in xyz format. The 

symbol orientation value allows the user to rotate the symbol of the connection point 

in the next tab Vessel View. 

 
Table 3.2 Fairlead coordinates 

 

Name X [m] Y [m] Z [m] 
Symbol 

orientation 

Fairlead 1 91 5.8 20 0 

Fairlead 2 -97 9.7 18.5 0 

Fairlead 3 77 14 19.2 0 

Fairlead 4 -82 13.4 18.5 0 

Fairlead 5 48 15.1 18.5 0 

Fairlead 6 -53 15.2 18.5 0 

 

5. Go to the Winch data tab. Similarly, copy and paste the following values into the 

winches table.  
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Table 3.3  Winch coordinates 

 

Name X [m] Y [m] Z [m] 
Symbol 

orientation 

Winch 1 86 5.8 20 0 

Winch 2 -79 9.7 18.5 0 

Winch 3 78 -1 19.2 0 

Winch 4 -82 4.4 18.5 0 

Winch 5 48 4.3 18.5 0 

Winch 6 -53 5.5 18.5 0 

 

6. Leave the Chain data and Fender connection data tabs as default. 

7. The final Vessel view tab shows the position of the fairleads and winches with 

respect to the mean deck level (defined by the deck plane height value) (red line) 

and water plane (defined by draft) of the vessel (orange). Note that only the mean 

deck level has been shown here and that simultaneous visualisation of multiple deck 

levels is not supported. Often, the far most fore/aft fairleads are located on higher 

decks. In this case, they will thus appear as located outside the red line.  

 

 

 
 

Figure 3-17 Vessel view window showing waterplane area (orange), mean deck level (red) and position of fairleads and 
winches 

 

Dialog: Port Data 
The Port data tab allows the user to position and visualise the bollards and fenders within 

the model domain.  

 

1. Click on the Bollard data tab. Set the Map Projection to MGA 56. Copy and paste the 

following data into the bollard table. 

 
  



 MIKE 21 Maritime 

64 Mooring Analysis - © DHI A/S 

Table 3.4  Bollard coordinates and Symbol orientation 

 

Name X [m] Y [m] Z [m] Bollard profile 

Bollard 1 514385.53 6966835.65 4 Bollard Profile 

Bollard 2 514594.93 6966835.10 4 Bollard Profile 

Bollard 3 514411.20 6966807.42 1.9 Bollard Profile 

Bollard 4 514570.40 6966807.13 1.9 Bollard Profile 

Bollard 5 514476.63 6966836.64 4 Bollard Profile 

Bollard 6 514505.43 6966836.31 4 Bollard Profile 

 

2. Click on the Fender data tab. Set the Map Projection to MGA 56. Copy and paste the 

following data into the fender table. 

 
Table 3.5  Fender coordinates, profile and Symbol orientation 

 

Name X [m] Y [m] Z [m] Force dir. [deg] 

Fender 1 514448.54 6966839.46 2 90 

Fender 2 514533.54 6966839.43 2 90 

Fender 3 514476.74 6966839.45 2 90 

Fender 4 514505.44 6966839.44 2 90 

 

Under Fender profile, select the Fender profile created in the Material Profiles. M21 

MA allows the user to create several fender profiles from which to select. This also 

allows different fender types to be used within the same berth layout. 

3.9 Setup Mooring System 

Now that both vessel and shore based connection points have been specified, it is time to 

connect the entire mooring system together. The Mooring setup dialog allows the user to 

position the vessel in the domain correctly, create the mooring setup and visualise the 

vessel, connection points and bathymetry in the same window. 

 

Dialog: Mooring Setup (Mooring line data tab) 
 

1. Create the mooring arrangement as below 
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Table 3.6 Mooring setup for M21 MA 2D example 

 

Name Vessel Bollard Fairlead Winch 
Line 

profile 

Line 

pretension [t] 
Tail profile 

Line 1 Vessel 1 Bollard 1 Fairlead 1 Winch 1 Line1 10 None 

Line 2 Vessel 1 Bollard 2 Fairlead 2 Winch 2 Line1 10 None 

Line 3 Vessel 1 Bollard 3 Fairlead 3 Winch 3 Line1 10 None 

Line 4 Vessel 1 Bollard 4 Fairlead 4 Winch 4 Line1 10 None 

Line 5 Vessel 1 Bollard 5 Fairlead 5 Winch 5 Line1 10 None 

Line 6 Vessel 1 Bollard 6 Fairlead 6 Winch 6 Line1 10 None 

 

 

2. Click on the Vessel position and mooring lines tab.  

 

3. Set the map projection to MGA-56. Specify the following vessel coordinates:  

- Easting - 514488.9 

- Northing - 6966856.3 

4. Set the vessel rotation to 180 deg. 

 

5. The image shown in Figure 3-18 should show up on your screen showing the berth 

pocket depth (constant 15 m), vessel and shore based connection points and the 

vessel position. 

 

 

 
 
Figure 3-18 Moored vessel in port domain with mooring system connected 

 

 

Note: The  icon can be used to delete lines and, likewise, mooring lines can be 

attached using the  icon. 
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3.10 Environmental Forcings 

Dialog: Environmental conditions 
This dialog defines the environmental forcing on the vessel i.e. wind, currents, first order 

waves and 2nd order wave drift forces. 

 

1. Physical Parameters dialog:  

- Set Density of water to 1024.61 [kg/m3] 

- Set Density of air to 1.28 [kg/m3] 

- Set Viscosity (water) to 1e-006 [m2/s] 

- Set Viscosity (air) to 1.48e-005 [m2/s] 

2. Leave the Drift Forces checkbox unticked 

 

For the purposes of this example we will not be using current or wind files as inputs to the 

M21 MA simulation. Therefore, leave these two dialogs set with ‘No current’ and ‘No 

wind’, respectively. 

 

Now that the mooring setup is ready and the environmental forcing has been included, the 

next step is to find the equilibrium position of the vessel under the proposed mooring 

system. This is outlined further in the following. 

3.11 Vessel Convergence 

In practice, to ensure an even load distribution amongst the mooring lines, the tension in 

the mooring lines is manually adjusted by winching in the ropes until the vessel is idle. In 

M21 MA, this process is done as an automated convergence process which finds the 

equilibrium position of the vessel under the proposed mooring system and forcings, 

except for the influence of first order waves. 

 

To do so, we will setup a convergence simulation. This will have a separate runtime and 

simulation mode and results from this will be used as an initial condition to the final M21 

MA computation. The M21 MA simulation must be run in convergence mode prior to 

running in Final computation mode to ensure a reasonable initial vessel displacement, 

which during the final computation mode leads to more accurate modelling of the moored 

vessel motions. 

 

 
 
Figure 3-19 Simulation Mode - Convergence 

 

Please follow the steps below to run the simulation in convergence mode: 

 

Dialog: Time 
1. Set the No. of Timesteps to 500 

2. Set the Time step interval to 1 
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3. Set the Simulation start date to 27-Feb 2011 10:00:00. This must match the date in 

the HD simulation. 

4. Set the No. of warm up steps to 0 

5. Set the No. of warm down steps to 0 

Dialog: Simulation Mode 
6. Set the Simulation Mode to Convergence mode as shown in Figure 3-19. 

Dialog: Convergence Parameters 
7. Set the Max no. iterations to 100 

8. Set the Line convergence threshold to 0.5 [%] This sets the simulation to converge 

when the dynamic line tensions in all lines are within 0.5% of the specified pretension 

values. 

Dialog: Vessel Displacements 
9. Apply default parameters 

Dialog: Outputs 
10. Select the following output files:  

- Convergence_line_pretension_deviation.dfs0 

- Convergence_lforces.dfs0 

- Convergence_Vessel 1_motions.dfs0 

In the MIKE ribbon, Go to Run → Start Simulation →OK. The simulation will run and a 

summary will appear in the simulation window at the bottom of the MIKE page. A 

message Successful Completion will appear. Check that the final line forces 

(Convergence_lforces.dfs0) are within 0.5% of the specified value and that the 

convergence deviation values (Convergence_line_pretension_deviation.dfs0) are small. 
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Figure 3-20 Final line pretensions after successful convergence shown in 

Convergence_lforces.dfs0 file  
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Figure 3-21 Convergence deviation values shown in Convergence_line_pretension_deviation.dfs0 

file 

 

Note: If a Convergence Mode run is not executed prior to the final time-domain 

computation (Final computation mode), the mooring system can cause the vessel to 

move. This will change the tension in each mooring line. For unbalanced mooring 

systems, the vessel response can be so significant that tension in some lines disappear 

completely. The subsequent vessel response in an incident wave/current/wind field will 

resultantly be significant different to specified design conditions and will most often be 

regarded as a serious flaw in the model setup. 

 

3.12 Final M21 MA Simulation 

Once the vessel has successfully converged, we are now ready to run the final M21 MA 

simulation. Please follow the steps below. 

 

Dialog: Time 
1. Continue using the 2D_Example.m21ma, or alternatively skip the following steps 2-

11 and use the prepared setup final_2D_Example.m21ma 

2. Set the No. of Timesteps to 16380 

3. Set the Time step interval to 0.25 

4. Set the Simulation start date to 27-Feb 2011 10:00:00. This must match the date in 

the HD simulation 
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5. Set the No. of warm up steps to 50  

6. Set the No. of warm down steps to 0 

 

Dialog: Simulation Mode 
7. Set the Simulation mode to Final computation mode 

 

Dialog: Wave 
8. Go to the Wave tab dialog:  

- Click on the dropdown list for Wave type and select Wave field 

- Click on the box to include warm up/down: 

 
- Set Format to Varying in time and domain  

- Set Lower frequency to 0 [Hz] 

- Set Upper frequency to 0.5 [Hz] 

- Set Power (N) to 12. This sets the FFT size (2N) to 4096 

Under Data file and items, click on the Select button and select the newly created Grid 

file. Select the grid (.dfs2) file from Section 3.4 where the time steps were extended to 

4096 steps. 
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Figure 3-22 Selecting wave input file for M21 MA simulation  
 

9. Save the setup file. 

 

If you have followed the steps shown in the guide, the wave file should have the correct 

time and items and a green tick symbol will appear  in the GUI tree in the 

M21 MA editor. If this does not appear, go to the Constraints Info tab shown in Figure 

3-22. This will show you exactly which item/setting is causing M21 MA to reject the input 

file. 

 

Dialog: Vessel Displacements 
Click on the ‘load’ button to load the initial (equilibrium) position of the vessel, obtained from the 
previous convergence mode simulation. You should see the numbers load automatically in the table 
as per  
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10. Figure 3-23. 

 

 

 
 
Figure 3-23 Initial displacement of moored vessel 

 

Dialog: Outputs 
11.  Select the following outputs:  

- Lpositions.dfs1 

- lforces.dfs0  

- fforces.dfs0  

- bforces.dfs0 

- Vessel 1_motions.dfs0 

- Vessel 1_mforces.dfs0 

- Vessel 1_selev.dfs0 

- Vessel 1_diff_forces.dfs0 

12. Set the vessel motion type to ‘Relative to displaced position’. 

 

13. Go to Run → Start Simulation and click OK. A summary of the run will appear in the 

window and a ‘Successful Completion’ should appear. 

 

14. Check either the log file (created automatically in the .m21ma setup folder) or the 

Simulation window, to make sure that neither the fender compression nor mooring 

line tensions exceeded acceptable levels.  

 

15. Open the newly created Vessel1_motions.dfs0 file and plot the Surge, Sway and 

Yaw motions. You should see that the vessel is stable until around 11:05 when the 

passing vessel generated displacement waves arrive at the berth and induce a large 

surge motion of the moored vessel. Motions in the other degrees of freedom are 

relatively small. Your plotted surge, sway and yaw motions should appear as shown 

in Figure 3-24. 
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Figure 3-24 Passing vessel induced moored vessel motions - surge, sway and yaw 

3.13 Visualise Vessel Movements in 3D 

It is possible to visualise the vessel movements by using MIKE Animator Plus.  

MIKE Animator Plus is a digital video production studio that enables you to turn e.g. MIKE 

21 model results into 3D video presentations.  

 

The results from the MIKE 21 Mooring Analysis module include a time series file with 

vessel motions. By using information from this together with a 3D solid representing the 

vessel, and data files with bathymetry and time-varying water level it is possible to use 

MIKE Animator Plus to create an informative animation of the vessel movements for the 

given mooring situation. 

 

The following sections describe how to setup MIKE Animator Plus to visualise the findings 

from the MIKE 21 Mooring Analysis model.  
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Note that you can still visualise the data if you do not have a license for MIKE Animator 

Plus, however in that case a DHI icon will be displayed in front in the graphics window. 

 

All references to file locations in the following are given with reference to the top folder 

.\MIKE_21\Maritime\MooringAnalysis\2D Wave Forcing. 

3.13.1 Generate input files for MIKE Animator Plus 

Before opening MIKE Animator Plus you must ensure the input data files fits the purpose. 

This example displays the results for 9 minutes at the end of the simulation. 

For better overview in the MIKE Animator Plus setup, new files are saved to the folder 

dedicated the MIKE Animator Plus setup: \MAPlus. 

Domain area 

The wave forcing simulation is carried out using the MGA-56 map projection, and the 

vessel location is defined as (514488.88 m, 6966854.82 m). However, the vessel motion 

output from the mooring simulation is always defined relative to the local amidship 

position of the vessel with an origo of (0,0). In order to show the vessel movements 

together with the 2D wave forcings, the two types of input must relate to the same 

coordinate system.  

 

An easy way to do this is to define a local map projection, based on the MGA-56 

coordinate system, but with a different origin corresponding to the ships local origo.  

This can be achieved by modifying the false easting and northing as follows: 

 New False Easting   = Old false Easting – Easting ship 

 New False Northing  = Old False Northing – Northing Ship 

 

The file MGA56_Local.prj reflects the local coordinate system described above and must 

be imported into MIKE Zero before further use: 

 

1. Open MIKE Zero and select File → Options → Edit Map Projections … 

2. Select Import Projection File…’ 

3. Select the file MGA56_Local.prj and press OK.  

Now you can use this map projection in files for the MIKE Animator Plus setup. 

Surface elevation 

The surface elevation and bathymetry for the MIKE Animator Plus setup are derived from 

the previously calculated wave forcing: 

 

1. Go to MIKE Zero and open the file ‘Grid1_Extended.dfs2’.  

2. Select Tools → Crop… 

3. Select the item ‘Total water depth’ and set the start date as 2011/02/27 10:59.16’, 

corresponding to the last 540 time steps. Save as Waterlevel_Local.dfs2 and press 

OK. 
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Figure 3-25 Cropping data to relevant extent 

 

4. Select Edit → Time steps… 

5. Change the Start Time to 2011/02/27 10:00:00 and press OK. (note that his setting is 

shifted for the animation only). 

6. Select Edit → Items… 

7. Change the Item description and Item type to Water level and press OK. 

8. Select Tools → Calculator… 

9. Specify the expression s = s-15 in order to derive the water surface. Go to the 'Sub-

Set' tab and make sure to select all time steps. Then press OK. 

10. Select Edit → Geographical Information… 

11. Select the newly imported map projection MGA56-Local, press Open and OK. 

12. In the pop-up window, select to ‘Keep “Geographical coordinates” and derive “Map 

projection coordinates”. This will result in a new origin for the 2D data as (-149.88 m, 

-45.82 m) in the local coordinate system. 
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Figure 3-26 Changing map projection 

 

13. Save the resulting dfs2 file in the following location: .\MAPlus\Waterlevel_Local.dfs2 

Note that the bathymetry is contained in the file as a static item.  

 

Vessel Movements 

In order to visualise the movements of the vessel in MIKE Animator Plus a 3Dsolid (.3ds) 

can be linked to a trajectory file. In this example the 3Dsolid Container.3ds is selected as 

a representative for the vessel. 

 



Example: 2D Wave Forcing (Port of Brisbane, Passing Vessel Induced Moored Vessel Motions)  

 77 

 
 
Figure 3-27 Container.3ds as displayed in MIKE Animator Plus.  

The cross shows the origin of the 3D solid in its local coordinate system  

 

The MIKE 21 Mooring Analysis simulation creates an output file with resulting vessel 

movements relative to the origin (0,0). As the selected 3D solid is defined with a local Z-

level origin at the bottom of the ship, it is necessary to modify the vessel motion values to 

position the vessel correctly with the water level. Also, the item descriptions need to be 

modified in order to meet the standard for trajectory files in MIKE Animator Plus. For 

simplicity the time step in the file is modified to match the water level, i.e. 1 second. 

 

1. In MIKE Zero create a new MIKE Zero Toolbox file and save it as 

‘GenerateTSData.mzt’. 

2. Expand the ‘Time Series’ section and double click on ‘Interpolate Time Series’. 
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Figure 3-28 MIKE Zero Toolbox: Interpolating Time Series 

 

3. Create a new setup called ‘MAPlus Vessel Movements file’. 

4. Select the output file .\Setups\Final 2D_Example.m21ma - Result Files\Vessel 

1_motions.dfs0’ and select all six items in the file. Press OK and Next. 

5. Define ‘Start time’ as 27/02/2011 10:59.16’ and ‘End time’ as 27/02/2011 11:08:15. 

Set the time Interval to 1 second. Press Next. 

6. Specify the new output file as .\MAPlus\Vessel1_motions_MAPlus.dfs0 

7. Press next and click on ‘Execute’ to run. 

8. At successful completion, a pop up box saying ‘Interpolation succeeded’ will show 

up. Click ‘OK’ and ‘Finish’ and save the setup as ‘GenerateTSData.mzt’. 

Now it is necessary to modify the dfs0 file to match the requirements for a trajectory file 

for this MIKE Animator Plus setup. 

 

9. Open Vessel1_motions_MAPlus.dfs0 in Time Series Editor 

10. Select Edit → Properties… 

11. Modify the Start time to 27/02/2011 10:00:00 and press OK to match the arbitrary 

start time for the animation. 

12. Subtract 10 m from the third item (Heave) to account for the Draft of the vessel, see 

Figure 3-29. Press OK and Save 
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Figure 3-29 Modifying position of vessel to accommodate local coordinate system of 3Dsolid.  

 

13. Change the item descriptions to meet MIKE Animator Plus requirements as follows:  

a. Click Edit → Properties …  

b. Change  item type for item 1 (Surge) to be ‘Geographical coordinate’ 

c. Change  item type for item 2 (Sway) to be ‘Geographical coordinate’ 

d. Change  item type for item 3 (Heave) to be ‘Item geometry 3-dimensional’ 

e. Leave item types for item 4 to item 6 as is (Angles) 

Click OK and save the file. 
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Figure 3-30 Valid item descriptions in trajectory file for MIKE Animator Plus 

3.13.2 Create a MIKE Animator Plus setup 

The set of steps below outline how to create a new MIKE Animator Plus setup. 

 

The first task is to create a setup to display the initial conditions. After that the MIKE 

Animator Plus setup can be extended to make an animation by including time varying 

data. Finally an additional scene is created to show the overall wave forcings.  

Initial conditions 

1. Open the MIKE Animator Plus editor. It can be located by searching for it in the 

Windows start menu. 

2. Click ‘File’ → ‘Insert’ → ‘Scene’ and select the wave forcings file  

.\MAPlus\Waterlevel_Local.dfs2 

3. Highlight ‘MIKE 21 file – Waterlevel_Local.dfs2’ in the property tree and double-click 

variable ‘Bathymetry’ to select to show bathymetry. 

4. Click on ‘Scene’ and select the ‘Fill’ tab. Click on ‘Fountain fill’ to change the colour of 

the background. 

5. Select the ‘View’ tab and change the Focalpoint parameters to (0,0,0) and the 

Viewpoint parameters to (100,150,40) as shown in Figure 3-31. 
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Figure 3-31 Defining View settings in MIKE Animator Plus  

 

6. Highlight ‘MIKE 21 file – Waterlevel_Local.dfs2’ in the property tree, right-click 

variable ‘Waterlevel’, and select ‘Surface - Mapped to magnitude’ to show water 

level. 

7. Select the ‘Palette’ tab and right-click ‘Palette’. 

8. From the drop-down menu select ‘Preset’ and ‘Water’, see Figure 3-32. 
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Figure 3-32 Adding data to existing scene 

 

9. ’Click ‘File’ → ‘Save Layout’ and save the setup to the new file 

.\MAPlus\Vessel_motions.lyt 

10. Right-click ‘Scene’ and select ‘Load data...’ 

11. Select the 3Dsolids file .\MAPlus\Container.3ds and double-click the ‘Solids Model’ 

variable to display the solids file in the graphics window. 

 

12. Now scale the Solids Model to resemble the outline of the vessel used in the Mooring 

Analysis simulations. Set the variables as follows:  

a. Uncheck ‘Uniform Scaling’ 

b. Set X extent to 193.43 m 

c. Set Y extent to 31.424 m 

Set Z extent to 28 m (twice the deck height).  

13. To position the Solids Model correctly in the vertical for the initial time step, go to the 

‘Solids’ tab and change the translation in the Z-domain to -10 m. 

14. Click ‘File’ → ‘Save Layout’ and save the setup. 
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Figure 3-33 View of Initial conditions after scaling and repositioning 3DS solid 

Animation 

1. Click ‘Insert’ → ‘Clock’ to add a clock to the graphics window. 

2. In the ‘Fill’ tab un-check ‘Solid fill’. 

3. Click-and-drag the Clock object in the graphics-window to a position in the upper left 

corner. 

4. In the ‘Clock’ tab select the Source Figure to be ‘Figure 1 Scene’ and the Source File 

to be ‘File 1 – MIKE 21 file – Waterlevel_Local.dfs2’ 

 

(Now the clock will indicate the time stamp in the file while the animation is running).  
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Figure 3-34 Clock showing instant time step in animation 

 

5. Next click the Solids Model Object and select the ‘Trajectory’ tab. 

6. Define the Movement to ‘6 parameters’ and select the Source file 

.\MAPlus\Vessel1_motions_MAPlus.dfs0 

 

 
 
Figure 3-35 Specifying data file for vessel movement 
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7. Click ‘File’ → ‘Save Layout’ and save the setup (as Vessel_Motions.lyt) 

8. Click the ‘Play’ button to watch the vessel move and water level change in time. 

Combining Scenes in Animation 

It is possible to visualise from where the wave forcing originate from by adding an 

additional scene to the MIKE Animator Plus view that shows the passing vessel in a larger 

domain. 

 

1. Click ‘File’ → ‘Insert’ → ‘Scene’ and select the calculated wave forcings file   

.\HD\Setup\PassingVessel_Example.m21fm - Result Files\ 

Vessel_Induced_Flux.dfsu 

2. Highlight ‘MIKE 21/3 FM file – Vessel_Induced_Flux.dfsu’ in the property tree and 

right-click variable ‘Total water depth’ to create a ‘Surface - Mapped to magnitude’. 

(This will show the whole domain from above. Note the suppression of the water 

level indicating the passing vessel). 

 

 

Figure 3-36 Added new scene, after selecting variable ‘Total water depth’ 

 

3. Select ‘Scene mode’ to edit the layout of the new scene. 

4. Select the new scene and click the ‘Fill’ tab to un-check ‘Solid fill’. 

5. Set the Focalpoint to the location of the moored vessel in the MGA-56 domain 

(514488.88, 6966854.82, 15).  

6. Define the Viewpoint such that the Focalpoint indicator is shown in the top of the 

domain and the initial position of the passing vessel to the left. 
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Figure 3-37 Defined Focal point and Added new scene, after selecting variable ‘Total water depth’ 

 

7. Select the variable ‘Total water depth’ and click on ‘Palette’. 

8. Define the palette by blue colours to reflect the detailed variation around MWL and a 

darker value to show passing vessel. Save the palette file for future use. 

 

Figure 3-38 Defined colour scale to represent passing vessel and total water depth 
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9. Next insert the 3Dsolids file .\MAPlus\Container.3ds into the scene the same way as 

described previously. Scale the vessel in similar way but set the location of the 

vessel to (514488.88, 6966854.82, 5) to represent the location in the MGA-56 

domain.  

 

 

Figure 3-39 Location of moored vessel in overview scene  

 

10. Click ‘File’ → ‘Save Layout’ and save the setup under a new name: 

Vessel_Motions_CombinedScenes.lyt 

11. Click ‘Layout mode’ to view both scenes together along with the clock. Drag and 

rescale scenes with the mouse weel to place scenes as required. Change the 

Viewpoint by changing the Viewing distance to zoom into the respective domains. 

12. To insert a Colour legend for the water surface click ‘File’ → ‘Insert’ → ‘Legend’. 

 

13. Select the Palette source as ‘Scene 0 – File 0 – Waterlevel’ and accept the default 

location of the palette bar to the left in the view. 

 

14. To match the colour legend for the two scenes, click the ‘Waterlevel’ object and right-

click to Load the saved water depth palette. Change the palette values from 

representing total water depth to represent surface elevation by subtracting the still 

water depth, 15 m, from the original values. 
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Figure 3-40 Combined overview of scenes, clock and Legend  

 

15. Click ‘File’ → ‘Save Layout’ and save the setup. 

Click the ‘Play’ button to watch the vessel move and water level change in time. Because 

of the very small movements, the moored vessel is set to be static in the scene showing 

the overview.  
  



Example: Multibody Application  

 89 

4 Example: Multibody Application 

The step-by-step example in this Chapter demonstrates how to set up a MIKE 21 Mooring 

Analysis simulation for multibody application. The example calculates vessel motions for 

two adjacent vessels that are moored to each other. 

 

4.1 Step 1 - Launch Frequency Response Calculator 

As per the previous sections, the first step in this analysis is to create an FRC setup to 

calculate the frequency determined response of the two respective vessels. 

 

Create a new instance of the (.fresponse) editor or open the file Multibody.fresponse in 

the folder <example installation folder>\MIKE Zero Projects\MIKE_21\Maritime\ 

MooringAnalysis\MultiBody\FRC\Setup\ 

 

If you create a new (.fresponse) editor, save the file as ‘Multibody.fresponse’. 

4.2 Step 2 - Populate the FRC Setup with Data 

The sequential steps for all FRC GUI dialogs are described below: 

 

Dialog: Vessel Configuration  
Select New Vessel twice and define the vessel names as ‘Vessel 1’ and ‘Vessel 2’ 

respectively. Under common conditions, use the following values: Set Water depth 

to 25.142 m and Density of water to 1020 kg/m3. 

 

 
 
Figure 4-1 Vessel configuration dialog 

 

Leave the Vessel positions and System view tabs for the moment and proceed to 

the next step. 
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Dialog: Vessel Instance  
 

For Vessel 1, on the Vessel Characteristics tab, load the vessel grid ogv_v2.grd 

that is located here: <example installation folder>\MIKE Zero Projects\MIKE_21\ 

Maritime\MooringAnalysis\MultiBody\FRC\Inputs\VesselGrid\Bulk_Carrier_1.grd 

 

Enter the vessel parameter values as shown in Table 4.1.  

 
Table 4.1 Moored vessel parameters for Vessel 1 

 

Vessel Scaling (X-Dim)  0.872 

Vessel Scaling (Y-Dim) 0.781 

Vessel Scaling (Z-Dim) 1 

rxx 15.925 [m] 

ryy 72.725 [m] 

rzz 72.725 [m] 

Vertical Center of Gravity (ZG) 11.54 [m] 

Draft 9 [m] 

Deck plane height 25 [m] 

 

Leave the settings as default on the Freedom of Motion tab. 

 

For Vessel 2, on the Vessel Characteristics tab, load the vessel grid TSV_Fine.grd 

that is located here: <example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\MultiBody\FRC\Inputs\VesselGrid\ 

Bulk_Carrier_2.grd 

 

Enter the vessel parameter values as shown in Table 4.2.  

 
Table 4.2 Moored vessel parameters for Vessel 2 

 

Vessel Scaling (X-Dim)  0.850 

Vessel Scaling (Y-Dim) 0.947 

Vessel Scaling (Z-Dim) 1 

rxx 15.480 [m] 

ryy 57.375 [m] 

rzz 57.375 [m] 

Vertical Center of Gravity (ZG) 9.51 [m] 

Draft 14 [m] 

Deck plane height 20 [m] 
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Leave the settings as default on the Freedom of Motion tab. 

 

Dialog: Vessel Configuration 
Return to the Vessel Configuration dialog and go to the Vessel positions tab. 

Select the position type as Amidship in domain and define the respective vessel 

positions as following: 

 

Vessel 1: X-Position = -8.483 m, Y-Position = -0.0376 m 

Vessel 2: X-Position = 0.553 m, Y-Position = 43.0171 m 

 

Click on the System view tab to inspect the relative position of the two vessels. If the 

two vessels are not in full view, the view extent can be adjusted. 

 

 
 

Figure 4-2 Vessel configuration dialog (System view tab) 

 

Dialog: Computational Settings 
In this dialog, leave the settings as default:  Simulation mode = M21 Mooring 

Analysis compatible mode, and Number of frequencies to solve = 256. 
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Figure 4-3 Computational Settings dialog 

 

Dialog: Wave Drift Forces 
For this example, tick ‘Include wave drift forces’ in order to account for long period 

components in the wave field. 

 

 
 

Figure 4-4 Wave Drift Forces dialog 

 

Dialog: Outputs 
All output data and file names are pre-populated with default settings. Do not change 

any settings here. The Vessel response output file will be the basis for all 

subsequent analysis. 

 

Note that the Response Amplitude Operator (RAO) curves and exciting forces will be 

calculated and generated for each respective vessel. 
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Figure 4-5 Outputs dialog 

4.3 Step 3 – Run the FRC Simulation 

Save the (.fresponse) editor and launch the FRC simulation. 

4.4 Step 4 - Launch the MIKE 21 Mooring Analysis 

The next step is to create a M21 Mooring Analysis setup to compute the vessel motions 

for the two adjacent vessels that are moored to each other. 

 

Create a new instance of the (.m21ma) editor or open the file Multibody.m21ma in the 

folder <example installation folder>\MIKE Zero Projects\MIKE_21\Maritime\ 

MooringAnalysis\MultiBody\M21MA\Setup\ 

 

If you create a new (.m21ma) editor, save the file as ‘Multibody.m21ma’. 

 

 

 
 
Figure 4-6 Location of MIKE 21 Mooring Analysis setup editor 
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4.5 Step 5 - Populate the MIKE 21 Mooring Analysis setup 

Below all the sequential steps for all required M21 MA GUI dialogs are described in 

descending order: 

 

Dialog: Domain 
The first step in creation of a M21 MA model begins with selecting a Domain file. 

Load the domain file that is located here: <example installation folder>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Bathy\ 

bathy_cropped.dfs2 

 

Dialog: Time 
Here you specify the temporal conditions applying for the time-domain computation 

(simulation mode = final computation mode).  

 

Make the following: 

a. Set the No. of timesteps to 7200 

b. Set the timestep interval to 0.25 [s] 

c. Set the simulation start date to 01-01-1990 12:30:00 PM 

d. Set the No. of warm up time steps to 50 

e. Set the No. of warm down time steps to 50 

 

Dialog: Simulation mode 
Set this to be Convergence mode. 

 

Using convergence mode means that you prior to running the final time-domain 

simulation first will attempt to find the initial vessel displacement leading to a uniform 

tension distribution among all mooring lines. 

 

Subsequently, determining a proper initial vessel displacement is an important pre-

processing step to ensure a subsequent stable time-domain analysis. 

 

Dialog: Material Profiles 
Expand the node and go to Line profiles. 

 

1. Dialog: Line Profiles 

Insert two Line profiles. Denote the first line ‘Rope’ and the second line ‘Tail’. 

 

2. Dialogs: Line Profile instances 

On the Rope instance specify the following: 

a. Total breaking strength = 137 [t] 

b. Failure load = 50 [%] 

c. Linear damping coefficient = 0 [kg/s] 

d. Quadratic damping coefficient = 0 [kg/m] 

Select this line profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Lines\ 

HMPE-42mmDiameter.dfs0 

On the Tail instance specify the following: 

a. Total breaking strength = 191 [t] 

b. Failure load = 50 [%] 

c. Linear damping coefficient = 0 [kg/s] 

d. Quadratic damping coefficient = 0 [kg/m] 
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Select this line profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Lines\ 

OCIMF_Polyester_Polypropylene_or_mixed_Polyolefins_Broken-In.dfs0 

After this go to the Fender Profiles dialog. 

 

3. Dialog: Fender Profiles 

Insert two Fender profiles. Leave their default names as ‘SCN 2000 E1.5’ and 

‘Pneumatic Fender’ respectively. 

 

4. Dialog: Fender Profile instances 

On the SCN 2000 E1.5 instance specify the following: 

a. Max reaction force = 3290 [kN] 

b. Max deflection = 2 [m] 

c. Failure deflection = 72 [%] 

d. Fender friction coefficient = 0.2 

e. Linear damping coefficient = 0 [kg/s] 

f. Fender thickness = 2.5 [m] 

Select this fender profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Fenders\ 

Trelleborg_SuperCone_fender.dfs0 

On the Pneumatic Fender instance specify the following: 

a. Max reaction force = 3169 [kN] 

b. Max deflection = 3.3 [m] 

c. Failure deflection = 60 [%] 

d. Fender friction coefficient = 0.2 

e. Linear damping coefficient = 0 [kg/s] 

f. Fender thickness = 3.3 [m] 

Select this fender profile: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Fenders\ 

Trelleborg_Floating_Pneumatic_Fender.dfs0 

5. Dialog: Chain Profiles 

 

We will skip usage of chains in this setup, so no chains will be specified. 

 

6. Dialog: Bollard Profiles 

Insert one New profile and Go to… it. Then, specify the following: 

a. Max. horizontal bollard pull force = 2000 [kN] 

b. Max. vertical bollard pull force = 1000 [kN] 

c. Max. total pull force = 2500 [kN] 

d. Max. vertical line angle = 60 [deg] 

e. Safety threshold = 75 [%] 

 

Dialog: Vessels 
In this dialog you must select the vessel response file generated from the previously 

executed FRC setup: 

< example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\FRC\Setup\MultiBody.frespo

nse - Result Files\Vessel_Response.vre 

 

Once the (.vre) file has been successfully loaded into M21 MA, it will look like as 

shown in Figure 4-7  
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Figure 4-7  Vessels dialog after successful loading of (.vre) file  

 

 

Clicking ‘Go to …’ on the vessel instance  will take you to the vessel instance dialog. 

 

1. Dialog: Vessel 1 instance 

On the Vessel data tab, specify the data as shown in Table 4.3:  

 
Table 4.3 Vessel 1 data 

 

Longitudinal Area (Wind) 5426.43 [m2] 

Transverse Area (Wind) 863.96 [m2] 

Lpp 285.06 [m] 

Loading Condition 0 [%] 

Vessel Class User defined 
1 Lpp refers to the length perpendicular of the vessel 

 

Note that for user defined vessel class, you will have to import drag curves for the 

vessel: 

a. Select the wind drag curve: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Drag 

Curves\Wind\BulkCarrier.dfs0 

b. Select the current drag curve: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Drag 

Curves\Current\BulkCarrier.dfs0 

 

Apart from this, you will also see a summary of the vertical attributes from the (.vre) 

file. Among these only the deck plane is editable at this stage. Leave it as 25 m. 

 

On the Fairlead data tab, load in data for the full set of fairlead positions (vessel 

fixed) from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Vessel Spatial 

Attributes\vessel1_fairleads.xyz 

 

On the Winch data tab, load in data for the full set of winch positions (vessel fixed) 

from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Vessel Spatial 

Attributes\vessel1_winches.xyz 
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On the Fender connection tab, load in data for the full set of fenders (vessel fixed) 

from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Vessel Spatial 

Attributes\vessel1_fenderConnection.xyz 

 

These values are shown in Table 4.4 to Table 4.6. The X and Y values are relative to 

amidship of the vessel and the Z values are relative to the keel. 

 
Table 4.4 Fairlead positions relative to amidship at Vessel 1 

 

Name X [m] Y [m] Z [m] 

Fairlead 1 -145 7 25 

Fairlead 2 -145 -7 25 

Fairlead 3 -100 -20 25 

Fairlead 4 -60 -22 25 

Fairlead 5 60 -22 25 

Fairlead 6 110 -20 25 

Fairlead 7 130 -10 25 

Fairlead 8 138 0 25 

Fairlead 9 Multi -125 15 25 

Fairlead 10 Multi -120 17 25 

Fairlead 11 Multi -115 18 25 

Fairlead 12 Multi -110 19 25 

Fairlead 13 Multi -23 23 25 

Fairlead 14 Multi -20 23 25 

Fairlead 15 Multi 20 23 25 

Fairlead 16 Multi 23 23 25 

Fairlead 17 Multi 110 20.5 25 

Fairlead 18 Multi 115 19 25 

Fairlead 19 Multi 125 15 25 

Fairlead 20 Multi 120 17 25 
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Table 4.5 Winch positions relative to amidship at Vessel 1 

 

Name X [m] Y [m] Z [m] 

Winch 1 -130 7 25 

Winch 2 -130 -7 25 

Winch 3 -100 7 25 

Winch 4 -60 7 25 

Winch 5 60 7 25 

Winch 6 110 7 25 

Winch 7 115 -5 25 

Winch 8 123 5 25 

Winch 9 -130 9 25 

Winch 10 -130 -9 25 

Winch 11 -102 7 25 

Winch 12 -62 7 25 

Winch 13 62 7 25 

Winch 14 112 7 25 

Winch 15 115 -7 25 

Winch 16 123 7 25 

Winch 17 Multi -125 0 25 

Winch 18 Multi -120 2 25 

Winch 19 Multi -115 3 25 

Winch 20 Multi -110 4 25 

Winch 21 Multi -23 8 25 

Winch 22 Multi -20 8 25 

Winch 23 Multi 20 8 25 

Winch 24 Multi 23 8 25 

Winch 25 Multi 110 5.5 25 

Winch 26 Multi 115 4 25 

Winch 27 Multi 125 0 25 

Winch 28  Multi 120 2 25 
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Table 4.6 Fender connection positions relative to amidship at Vessel 1 

 

Name X [m] Y [m] Z [m] 

Fender connection 1 -62.557 22.61 10.15 

Fender connection 2 -22.557 22.62 10.15 

Fender connection 3 17.443 22.62 10.15 

Fender connection 4 77.443 22.18 10.15 

 

On the Vessel View tab, you can see overview of where the full set of fairleads, 

winches and fender connections are positioned relative to the vessel. It should look 

as seen in Figure 4-8. Note that some of the vessel attributes may appear to be 

missing (or not visible) with the full extent view. It is recommended that you zoom in 

to properly inspect them. 

 

 
 
Figure 4-8 Vessel view after fairlead, winch and fender connection positions have been specified for Vessel 1 

 

2. Dialog: Vessel 2 instance 

On the Vessel data tab, specify the data as shown in Table 4.7:  

 
Table 4.7 Vessel 2 data 

 

Longitudinal Area (Wind) 2478.32 [m2] 

Transverse Area (Wind) 396.65 [m2] 

Lpp 224.89 [m] 

Loading Condition 0 [%] 

Vessel Class User defined 

 

Similar to Vessel 1, you will have to import drag curves for the vessel: 

a. Select the wind drag curve: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Drag 

Curves\Wind\BulkCarrier.dfs0 
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b. Select the current drag curve: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Drag 

Curves\Current\BulkCarrier.dfs0 

 

Leave the deck plane as 20 m. 

 

On the Fairlead data tab, load in data for the full set of fairlead positions (vessel 

fixed) from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Vessel Spatial 

Attributes\vessel2_fairleads.xyz 

 

On the Winch data tab, load in data for the full set of winch positions (vessel fixed) 

from the file: < example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Vessel Spatial 

Attributes\vessel2_winches.xyz 

 

These values are as the ones shown in Table 4.8 to Table 4.9. The X and Y values 

are relative to amidship of the vessel and the Z values are relative to the keel. 

 
Table 4.8 Fairlead positions relative to amidship at Vessel 2 

 

Name X [m] Y [m] Z [m] 

Fairlead 1 -97 -13 20 

Fairlead 2 -90 -14.5 20 

Fairlead 3 -85 -15.5 20 

Fairlead 4 -80 -16.5 20 

Fairlead 5 -65 -17.5 20 

Fairlead 6 -60 -17.5 20 

Fairlead 7 60 -16.5 20 

Fairlead 8 65 -16 20 

Fairlead 9 80 -13.5 20 

Fairlead 10 85 -12.5 20 

Fairlead 11 89 -11.5 20 

Fairlead 12 93 -10 20 
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Table 4.9 Winch positions relative to amidship at Vessel 2 

 

Name X [m] Y [m] Z [m] 

Winch 1 -97 -5 20 

Winch 2 -90 -6.5 20 

Winch 3 -85 -6.5 20 

Winch 4 -80 -6.5 20 

Winch 5 -65 -6.5 20 

Winch 6 -60 -6.5 20 

Winch 7 60 -6.5 20 

Winch 8 65 -6.5 20 

Winch 9 80 -6.5 20 

Winch 10 85 -6 20 

Winch 11 89 -4.5 20 

Winch 12 93 -2 20 

 

On the Vessel View tab, you can see overview of where the full set of fairleads and 

winches are positioned relative to the vessel. It should look as seen in Figure 

4-9Figure 4-8. Note that some of the vessel attributes may appear to be missing (or 

not visible) with the full extent view. It is recommended that you zoom in to properly 

inspect them. 

 

 
 
Figure 4-9 Vessel view after fairlead and winch positions have been specified for Vessel 2 

 

Dialog: Vessel-Vessel Data 
Under this dialog, you will be able to see the two adjacent vessel and their respective 

vessel-fixed attributes, as shown in Error! Reference source not found.. You are t

hen able to define the mooring lines and fender connection between these two 

vessels. 



 MIKE 21 Maritime 

102 Mooring Analysis - © DHI A/S 

 

 
 

Figure 4-10 Vessel-vessel data view with their respective vessel-fixed attributes 

 

First, we will define the mooring lines between them. The mooring system that we 

would like to obtain is as given in Table 4.10. 

 

Each mooring line can be drawn/defined interactively by:   

a. Visual identification of the winch (first vessel) → fairlead (first vessel) → fairlead 

(second vessel) → winch (second vessel) pair, to span the mooring line 

b. Initiate the mooring line insertion by: clicking the Vessel-Vessel lines icon  

c. Perform the mooring line insertion by moving the cursor and clicking the 

following in sequence: Winch icon (vessel from) → Fairlead icon (vessel from) 

→ Fairlead icon (vessel to) → Winch icon (vessel to) 

 

If you make an error by connecting some incorrect attributes, then delete the line by 

selecting the delete line icon  and subsequently clicking on the given line. 

 

After insertion of all mooring lines, the vessel-vessel mooring setup should look like 

the one shown in Figure 4-11. 

 



Example: Multibody Application  

 103 

 
 
Figure 4-11 System view after definition of vessel-vessel mooring lines 

 

To complete the mooring line definitions, go to the Vessel-vessel line data tab and 

set the line profile, line pretension, tail profile and tail length values for all the vessel-

vessel mooring lines (V-V Line 1 – V-V Line 12) according to the values shown in 

Table 4.10. 

 

Make sure that the vessel-vessel lines go from vessel 1 to vessel 2 and not vice 

versa! 
 
Table 4.10 The full vessel-vessel lines definition 

 

Name Vessel 

(from) 

Winch 

(from) 

Fairlead 

(from) 

Vessel 

(to) 

Winch 

(to) 

Fairlead 

(to) 

Line 

profile 

Line pre-

tension (t) 

Tail 

profile 

Tail 

length 

V-V  

Line 1 

Vessel 

1 

Winch 

17 

Fairlead 

9 

Vessel 

2 

Winch 

1 

Fairlead 

1 Rope 10 None 0 

V-V  

Line 2 

Vessel 

1 

Winch 

18 

Fairlead 

10 

Vessel 

2 

Winch 

2 

Fairlead 

2 Rope 10 None 0 

V-V  

Line 3 

Vessel 

1 

Winch 

19 

Fairlead 

11 

Vessel 

2 

Winch 

3 

Fairlead 

3 Rope 10 None 0 

V-V  

Line 4 

Vessel 

1 

Winch 

20 

Fairlead 

12 

Vessel 

2 

Winch 

4 

Fairlead 

4 Rope 10 None 0 

V-V  

Line 5 

Vessel 

1 

Winch 

21 

Fairlead 

13 

Vessel 

2 

Winch 

5 

Fairlead 

5 Rope 10 None 0 

V-V  

Line 6 

Vessel 

1 

Winch 

22 

Fairlead 

14 

Vessel 

2 

Winch 

6 

Fairlead 

6 Rope 10 None 0 
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Name Vessel 

(from) 

Winch 

(from) 

Fairlead 

(from) 

Vessel 

(to) 

Winch 

(to) 

Fairlead 

(to) 

Line 

profile 

Line pre-

tension (t) 

Tail 

profile 

Tail 

length 

V-V  

Line 7 

Vessel 

1 

Winch 

23 

Fairlead 

15 

Vessel 

2 

Winch 

7 

Fairlead 

7 Rope 10 None 0 

V-V  

Line 8 

Vessel 

1 

Winch 

24 

Fairlead 

16 

Vessel 

2 

Winch 

8 

Fairlead 

8 Rope 10 None 0 

V-V  

Line 9 

Vessel 

1 

Winch 

25 

Fairlead 

17 

Vessel 

2 

Winch 

9 

Fairlead 

9 Rope 10 None 0 

V-V  

Line 10 

Vessel 

1 

Winch 

26 

Fairlead 

18 

Vessel 

2 

Winch 

10 

Fairlead 

10 Rope 10 None 0 

V-V  

Line 11 

Vessel 

1 

Winch 

28 

Fairlead 

20 

Vessel 

2 

Winch 

11 

Fairlead 

11 Rope 10 None 0 

V-V  

Line 12 

Vessel 

1 

Winch 

27 

Fairlead 

19 

Vessel 

2 

Winch 

12 

Fairlead 

12 Rope 10 None 0 

 

Next, we will define the fender connections between the two vessels. The vessel-

vessel fender connections can be defined by following: 

a. Initiate the insertion of fender connection by: clicking the Vessel-Vessel 

fenders icon  

b. Moving the cursor and clicking on the F. Con icon (see Figure 4-12). 

 

 
 
Figure 4-12 Example of a newly defined fender connection (dotted white circle with arrow icon showing the fender force 

direction) 

 

To complete the fender connection definitions, go to the Vessel-vessel fender data 

tab. Set the fender force direction and fender profile for all the vessel-vessel fender 

connections (V-V Fender 1 – V-V Fender 4) with the values shown in Table 4.10. 
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A fender force direction of 90 [deg] means that fender forces goes towards north (i.e. 

towards Vessel 2). 

 
Table 4.11 The full vessel-vessel fender definition 

 

Name Vessel 

(connected) 

Fender connection Vessel 

(affected) 

Force dir. [deg] Fender profile 

V-V Fender 1 Vessel 1 Fender connection 1 Vessel 2 90 Pneumatic Fender 

V-V Fender 2 Vessel 1 Fender connection 2 Vessel 2 90 Pneumatic Fender 

V-V Fender 3 Vessel 1 Fender connection 3 Vessel 2 90 Pneumatic Fender 

V-V Fender 4 Vessel 1 Fender connection 4 Vessel 2 90 Pneumatic Fender 

 

Dialog: Port Data 
On the Bollard data tab, set the map projection to UTM-30. Then load in data for the 

full set of bollard positions (port/land fixed) from the file: < example installation folder 

>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Port 

Data\Bollards.xyz 

 

Then, select the Bollard profile Bollard Profile by clicking into the cells of the 

corresponding column. 

 

On the Fender data tab, set the map projection to UTM-30. Then load in data for the 

full set of fender positions (port/land fixed) from the file: < example installation folder 

>\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Port 

Data\Fenders.xyz 

 

The bollard and fender positions in the grid series (.dfs2) domain are shown in Table 

4.12 and Table 4.13. The Z values are relative to the water surface. 

 
Table 4.12 Bollard positions in local domain 

 

Name Easting [m] Northing [m] Z [m] Bollard profile 

Bollard 1  835283.7619 718.8273511 3 Bollard Profile 

Bollard 2 835255.4776 690.5430798 3 Bollard Profile 

Bollard 3 835205.9802 556.1927914 3 Bollard Profile 

Bollard 4 835202.4446 552.6572575 3 Bollard Profile 

Bollard 5 835071.6299 506.6953167 3 Bollard Profile 

Bollard 6 835043.3456 478.4110455 3 Bollard Profile 

 

  



 MIKE 21 Maritime 

106 Mooring Analysis - © DHI A/S 

Table 4.13 Fender positions in local domain 

 

Name Easting [m] Northing [m] Z [m] Force dir. [deg] Fender profile Vessel (affected) 

Fender 1 835263.1143862 612.1956485 2 315 SCN 2000 E1.5 Vessel 1 

Fender 2 835220.6879793 569.7692416 2 315 SCN 2000 E1.5 Vessel 1 

Fender 3 835192.4037081 541.4849704 2 315 SCN 2000 E1.5 Vessel 1 

Fender 4 835135.8351656 484.9164279 2 315 SCN 2000 E1.5 Vessel 1 

 

Set all fender profiles to Fender Profile 1 while the fenders force directions to 315 

[deg] (meaning the fender forces goes towards south-east). The port-fixed fenders 

will be acting towards Vessel 1 (i.e. vessel affected). 

 

On the Port View tab, you can see where the bollards and fenders are positioned in 

the domain. The full set of bollards and fenders should look like in Figure 4-13. Note 

that some of the port-fixed attributes may appear to be missing (or not visible) with 

the full extent view. It is recommended that you zoom in to properly inspect them. 

 

 
 
Figure 4-13 Bollard and fender positions 
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Dialog: Mooring Setup 
On the Vessel position and mooring lines tab, set the map projection to UTM-30. 

Specify the vessel position to be at (easting, northing) = (835222, 537) [m] and a 

vessel rotation of 225 [deg], and click Apply.  

 

You will now see the position of the two moored vessel relative to the port-fixed 

attributes, as shown in Figure 4-14. 

  

 
 
Figure 4-14 Vessel inserted into domain 

 

The next step is to define the mooring lines between Vessel 1 and the port-fixed 

bollards. The mooring system we would like to obtain is as given in Table 4.14. 

 

Each mooring line can be drawn/defined interactively by:   

a. Visual identification of the relevant winch-fairlead-bollard pair, to span the 

mooring line 

b. Initiate the mooring line insertion by: clicking the Vessel-Berth lines icon  

c. Perform the mooring line insertion by: clicking the relevant winch icon, move the 

cursor to the relevant fairlead icon, clicking on the fairlead icon, continue the line 

to the bollard, and finally clicking on the bollard icon. 

 

After insertion of all mooring lines, the mooring setup should look like the one shown 

in Figure 4-15. 
 

To complete the mooring line definitions, go to the Mooring line data tab and set the 

line profile, line pretension, tail profile and tail length values for all the mooring lines 

(Line 1 – Line 16) according to the values shown in Table 4.14. 
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Figure 4-15 Vessel view after definition of all mooring lines 

  
Table 4.14 The full mooring line definitions 

 

Name Vessel Bollard Fairlead Winch 
Line 

profile 

Line 

pretension [t] 

Tail 

profile 

Tail length 

[m] 

Line 1 Vessel 1 Bollard 1 Fairlead 1 Winch 9 Rope 10 Tail 11 

Line 2 Vessel 1 Bollard 1 Fairlead 1 Winch 1 Rope 10 Tail 11 

Line 3 Vessel 1 Bollard 1 Fairlead 2 Winch 2 Rope 10 Tail 11 

Line 4 Vessel 1 Bollard 2 Fairlead 2 Winch 10 Rope 10 Tail 11 

Line 5 Vessel 1 Bollard 2 Fairlead 3 Winch 11 Rope 10 Tail 11 

Line 6 Vessel 1 Bollard 2 Fairlead 3 Winch 3 Rope 10 Tail 11 

Line 7 Vessel 1 Bollard 3 Fairlead 4 Winch 12 Rope 10 Tail 11 

Line 8 Vessel 1 Bollard 3 Fairlead 4 Winch 4 Rope 10 Tail 11 

Line 9 Vessel 1 Bollard 4 Fairlead 5 Winch 5 Rope 10 Tail 11 

Line 10 Vessel 1 Bollard 4 Fairlead 5 Winch 13 Rope 10 Tail 11 

Line 11 Vessel 1 Bollard 5 Fairlead 6 Winch 6 Rope 10 Tail 11 

Line 12 Vessel 1 Bollard 5 Fairlead 6 Winch 14 Rope 10 Tail 11 

Line 13 Vessel 1 Bollard 5 Fairlead 7 Winch 15 Rope 10 Tail 11 
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Line 14 Vessel 1 Bollard 6 Fairlead 7 Winch 7 Rope 10 Tail 11 

Line 15 Vessel 1 Bollard 6 Fairlead 8 Winch 8 Rope 10 Tail 11 

Line 16 Vessel 1 Bollard 6 Fairlead 8 Winch 16 Rope 10 Tail 11 

 

Dialog: Environmental Conditions 
Expand the nodes and go to Physical Parameters. 

 

1. Dialog: Physical Parameters 

In this dialog, you should use the default values: 

2. Density of water = 1020  [kg/m3] 

3. Density of air = 1.28  [kg/m3] 

4. Viscosity (water) = 10-6  [m2/s] 

5. Viscosity (air) = 1.48 • 10-5  [m2/s] 

 

6. Dialog: Drift Forces 

Drift forces are not included. 

 

7. Dialog: Current 

Do not include a current field. 

 

8. Dialog: Wind 

Do not include a wind field. 

Dialog: Convergence Parameters 
In this dialog, specify the following values: 

a. Max no. of iterations = 5000 

Line convergence threshold = 1 % 

Dialog: Vessel Displacements 
Apply default parameters for both Vessel 1 and Vessel 2. 

Dialog: Outputs 
Apply the default output file names. All output files except ‘External forces’ and 

‘Chain forces’ are included. 

 

Ensure that all data in the (.m21ma) setup are saved. 

4.6 Step 6 – Run the Simulation in Convergence Mode 

Save the (.m21ma) editor and launch the M21 MA simulation. 

4.7 Step 7 – Populate the MIKE 21 Mooring Analysis setup with final 
execution data 

Dialog: Simulation Mode 
Switch from Convergence Mode to Final Computation Mode. This will then open the 

Wave dialog under the Environmental Conditions dialog in the navigation tree. 

 

Dialog: Wave 
Use the following parameters: 

a. Select Wave type = Wave field 
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b. Check ‘Include warm up/down’ 

c. Select Format = Varying in time and domain 

d. Set Lower frequency = 0 [Hz] 

e. Set Upper frequency = 0.5 [Hz] 

Set Power (N) to 12 (leading to FFT size = 4096)  

Load in the wave data from the following file: 

< example installation folder >\MIKE Zero 

Projects\MIKE_21\Maritime\MooringAnalysis\Multibody\M21MA\Inputs\Waves\ 

2D_cropped.dfs2 

 

Dialog: Vessel Displacements 
Click on the ‘Load’ button. The initial vessel displacement fields for the six degree of 

motions (i.e. Surge, Sway, Heave, Roll, Pitch and Yaw) will be automatically 

populated with data from the final iteration of the output files: 

 

a. Convergence_Vessel_1_motions.dfs0 for Vessel 1 

Convergence_Vessel_2_motions.dfs0 for Vessel 2 

This action ensures that the final time-domain computation starts from vessel states 

where there is sufficient tensional equilibrium in all mooring lines. 

 

Dialog: Final Output 
Leave the output file settings as default. All output files except ‘External forces’ and 

’Chain forces’ are included. 

 

Set the vessel motion type to ‘Relative to displaced position’. 
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Figure 4-16 Final output dialog 

4.8 Step 8 – Run the Final Time-Domain Simulation 

Save the (.m21ma) editor and launch the M21 MA simulation. From the log result file, you 

will see that the critical load for the vessel-berth lines and vessel-vessel lines were never 

exceeded. 
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Figure 4-17 Log result file after the simulation was completed 

 

Notice that in the result folder, there are two sets of output files for the two vessels 

respectively. To inspect the model results, you can plot the vessel motions on MIKE Zero 

Plot Composer. As the two vessels are moored to each other, the surge responses are 

similar between them. However, Vessel 1 is predicted to have larger roll than Vessel 2. 
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Figure 4-18 Time series of vessel motions for Vessel 1 and Vessel 2 
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5 Example: AutoMoor™ Mooring System  

The step-by-step example in this Chapter demonstrates how to set up a Trelleborg 

AutoMoor™ automatic mooring unit in a MIKE 21 Mooring Analysis simulation through 

text edits to the *.m21ma input file. The example calculates vessel motions in 6-DoF (Six 

Degrees of Freedom) of a moored tanker subjected to a time series of incident wave 

conditions (0D wave forcing). This example is the same as the example provided in 

section 2 (Example: 0D Wave Forcing on a Vessel) but instead of mooring lines, two  

AutoMoor™ units are used. Therefore, the vessel frequency response and mooring 

analysis setup are taken from that example. In this section, it is shown how to add 

AutoMoor™ to the setup file. 

This example’s files are available in the folder  

<example installation folder>\MIKE_21\Maritime\MooringAnalysis\AutoMoor Mooring 

 

5.1 Step 1 – Open the MIKE 21 Mooring Analysis Setup file with a text 
editor 

The MIKE 21 Mooring Analysis (.m21ma) editor under the Maritime subgroup of MIKE 21 

is used to model AutoMoor™. The GUI interface is not currently configured to enable the 

setup of AutoMoor™ units. The user therefore can make the mooring setup file using the 

GUI as presented in the previous examples. Then, to add AutoMoor™ units the setup file 

must be edited in a text editor environment (Figure 5-1).  

 

 
  

 
Figure 5-1 Location of MIKE 21 Mooring Analysis example for Trelleborg AutoMoor™ ®. 

5.2 Step 2 - Create an AutoMoor™ Profile 

In the ‘AutoMoor_Mooring_setup.m21ma’ file, under the section [MATERIAL_PROFILES], 

make a new section for AutoMoor™ profiles as shown in Figure 5-2. The AutoMoor™ 

user-defined input parameters are defined in this section. To include max vertical and 

horizontal angles and maximum Y extension in the AutoMoor™ direction, in the failure 

check of the AutoMoor™, the “include_max_...” must be set to 1. The failure_extension 

shows the percentage of the maximum extension length (this parameter is read from the 

force table file). For example, if user decides to consider failure when AM exceeds 0.85 of 

its maximum allowed extension, then failure_extension=85. Failure_deflection shows the 

same parameter for vertical and horizontal angles. The name of AutoMoor™ profile or 
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force table file is read in ‘file_name’. The file name should be changed to ‘C:\Program 

Files (x86)\DHI\2020\MIKE Zero\Templates\Maritime\MooringAnalysis\Material 

Profiles\AutoMoor Profiles\AutoMoor_T40_twin_arm_perArm.encrypt’ or the 

appropriate address containing this file. The initial length of AM is defined in ‘initial_length’ 

in meters. This is the parked length of AM before making attachment to the vessel’s hull. 

After connection the length is calculated based on the attachment point. That length is 

used in the force interpolations. The maximum tensile force of the AutoMoor™ is also 

defined by user through ‘max_tension_force’ in Newtons.  

 

 
 
Figure 5-2  AutoMoor profile in *.m21ma file. 

 

5.3 Step 3 – Create AutoMoor Units  

In the ‘AutoMoor_Mooring_setup.m21ma’ file, under the section [PORT_DATA], make a 

new section for AutoMoor™ units as shown in Figure 5-3. The number of Am units is 

defined in ‘MzSEPfsListItemCount’ and ‘number_of_automoors’. For each 

AUTOMOOR™, a name needs to be assigned. The coordinate of the connection point of 

the AutoMoor™ on the berth is defined as x, y and z. The same coordinate system used 

for fenders and bollards is used for AUTOMOOR™s. The AUTOMOOR™ direction is 

better to be defined as the nearest fender’s direction. This is because AUTOMOOR™ and 

fender together control the vessel motions. Fender works under compression while 

AUTOMOOR™ works under tension. The relevant material profile used for 

AUTOMOOR™ is defined in ‘automoor_profile’. The vessel that connects to the 

AUTOMOOR™, is defined in ‘vessel_affected’ which takes the vessel number.  

It is advised to arrange AUTOMOOR™s in the middle one third of the vessel. 
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Figure 5-3 Setup of AutoMoor™ units in *.m21ma file 

 

Based on the AUTOMOOR™ length and fender’s thickness, the connection point of 

AUTOMOOR™ on the berth is defined. The parked end of an AUTOMOOR™ must be 

behind the compressed fender’s tip.  

5.4 Step 4 – Control AutoMoor Effect in Mooring Simulation  

 

Under the section [OPTION_PARAMETERS] in (.m21ma) setup file, there are different 

options available to user to control the AM role in the mooring analysis. To consider AM in 

the mooring system, ‘IncludeAutomoor’ must be set to 1. If it is 0, then AM doesn’t 

contribute in the simulation. The option ‘IncludeAutoMoorFailure’ lets user to continue 

simulations after the failure of one or more AMs provided it sets to 0. If this parameter is 

set to 1, then simulations stops//fails upon the failure of first AM. If parameter 

‘IncludeAutomoorWithoutForce’ is set to 1, then AM has no effect on the mooring 

analysis, but the effect of vessel motions on the AM is calculated. In the practical uses of 

AM, this value is always set to 0. Parameter ‘IncludeAutomoorReattachment’ is always 

set to 0. In the current version of AM design, there is no possibility to release and reattach 

the unit during the operation. The option is there for future development. 

 

 
Figure 5-4 AutoMoor modes of simulation. 
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5.5 Step 5 – Define the AutoMoor™ output files  

In each of [CONVERGENCE_OUTPUT] and [FINAL_OUTPUT] sections in your setup 

*.m21ma file create two sections for AUTOMOOR™ forces and AUTOMOOR™ 

displacements. The [AUTOMOOR_XYZ] defines the result file name which includes the X, 

Y, Z, L, horizAngle, and vertAngle of all AUTOMOOR™s. Where, Y is the AUTOMOOR™ 

length in the initial AUTOMOOR™ direction, X is the deviation from initial direction on a 

horizontal plane and Z is the deviation from the initial position in the vertical plane. 

horizAngle=ATAN(X/Y), vertAngle=ATAN(Z/Y), and L is the total length of 

AUTOMOOR™. 

 

 

 
 
Figure 5-5 Define AutoMoor result files’ names. 

 

 

The [AUTOMOOR_FORCES] section takes the file name of the result file for 

AUTOMOOR™ forces. That file includes Fx, Fy, Fz (AUTOMOOR™ force components in 

local coordinate) and Ftot (the magnitude of AUTOMOOR™ total force) for all 

AUTOMOOR™s.  

The [AUTOMOOR_FORCES] section takes the file name of the result file for AM forces. 

That file includes Fx, Fy, Fz (AM force components in local coordinate) and Ftot (the 

magnitude of AM total force) for all AMs.  

 

 

5.6 Step 6 – Run MIKE21 MA FOR AutoMoor™ 

To execute the setup file which includes AutoMoor™ setups, make a bat file (make a new 

file in a text editor and save it as runFile.bat in the same folder as the setup file) and put 

the following command in it.  

 

set Path=%Path%;%DHI_MIKE_2020% 

start /w MzLaunch.exe .AutoMoor_Mooring_setup.m21ma 

 

You may need to change the addresses appropriately if the location of the setup file 

differs. Save the file and close it. By double clicking on the bat file, the program starts 

running in a command prompt environment. The simulation will be fast and produce the 

relevant output files for the time-domain analysis. However, the run time increases by 

increasing the number of AUTOMOOR™ units. If there is any error, it will be shown on 

the screen and will also be printed in the (.log) file. 
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NOTE: Do not open and save the .m21ma file in the MIKE GUI after making changes to 

this in a text editor to configure AutoMoor™ units as the GUI will not recognise these 

inputs and will remove these changes. 

5.7 Step 7 – Inspect Results 

  

The Operability Summaries for AutoMoor™ at the end of the simulation can be found at 

the end of the (.log) file produced by the engine. For this simulation the critical 

AutoMoor™ extension and deflections were never exceeded, indicating the mooring 

system dynamics is within the specified operating limits. 

 

 
 
Figure 5-6 Operability Summaries for AutoMoor™ from the engines .log file. 

 

In this example, the AutoMoor™ force time series are recorded in file ”aforces.dfs0”. The 

file can be easily opened in MikeZero (Figure 5-7). 

 

 
 
Figure 5-7 AutoMoor™ force results 

 

The forces are shown in [tone]. 

The AutoMoor™ displacement time series are saved in file “automoorXYZ.dfs0”. The file 

is readable in MIKE ZERO (Figure 5-8). 
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Figure 5-8 Time series of AutoMoors displacements. 

 

 

The lengths are shown in [meter] and angles in [Radian]. 
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